aboutsummaryrefslogtreecommitdiff
path: root/flakes/files-watcher/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flakes/files-watcher/flake.nix')
-rw-r--r--flakes/files-watcher/flake.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/flakes/files-watcher/flake.nix b/flakes/files-watcher/flake.nix
index 29ea428..3be566d 100644
--- a/flakes/files-watcher/flake.nix
+++ b/flakes/files-watcher/flake.nix
@@ -2,6 +2,8 @@
2 description = "Module to watch fo file changes to force restart systemd service"; 2 description = "Module to watch fo file changes to force restart systemd service";
3 outputs = { self }: { 3 outputs = { self }: {
4 nixosModule = { config, lib, pkgs, ... }: let cfg = config.services.filesWatcher; in with lib; { 4 nixosModule = { config, lib, pkgs, ... }: let cfg = config.services.filesWatcher; in with lib; {
5 # Necessary for situations where flake gets included multiple times
6 key = builtins.hashString "sha256" (builtins.path { path = self.sourceInfo.outPath; name = "source"; });
5 options = { 7 options = {
6 services.filesWatcher = with lib.types; mkOption { 8 services.filesWatcher = with lib.types; mkOption {
7 default = {}; 9 default = {};