aboutsummaryrefslogtreecommitdiff
path: root/deploy/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'deploy/flake.nix')
-rw-r--r--deploy/flake.nix5
1 files changed, 1 insertions, 4 deletions
diff --git a/deploy/flake.nix b/deploy/flake.nix
index cb7a973..f77528c 100644
--- a/deploy/flake.nix
+++ b/deploy/flake.nix
@@ -2,9 +2,6 @@
2 inputs = { 2 inputs = {
3 devshell.url = "github:numtide/devshell"; 3 devshell.url = "github:numtide/devshell";
4 nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable?dir=lib"; 4 nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable?dir=lib";
5 # Uncomment temporarily below value and replace with local path to
6 # your secrets, and replace "follows" key below to use it.
7 #secrets-local.url = "path:/home/immae/projets/mes_sites/nixops-secrets";
8 secrets = { 5 secrets = {
9 type = "git"; 6 type = "git";
10 url = "git+ssh://gitolite@git.immae.eu/perso/Immae/Config/Nix/Nixops/Secrets"; 7 url = "git+ssh://gitolite@git.immae.eu/perso/Immae/Config/Nix/Nixops/Secrets";
@@ -14,7 +11,7 @@
14 main-flake.inputs.secrets.follows = "secrets"; 11 main-flake.inputs.secrets.follows = "secrets";
15 }; 12 };
16 outputs = inputs@{ self, nixpkgs, main-flake, devshell, ... }: { 13 outputs = inputs@{ self, nixpkgs, main-flake, devshell, ... }: {
17 sops-vars-file = (inputs.secrets-local or inputs.secrets).vars-file; 14 sops-vars-file = inputs.secrets.vars-file;
18 devShells.x86_64-linux.default = devshell.legacyPackages.x86_64-linux.mkShell { 15 devShells.x86_64-linux.default = devshell.legacyPackages.x86_64-linux.mkShell {
19 env = [ 16 env = [
20 { name = "NIX_BUILD_TOP"; value = ""; } 17 { name = "NIX_BUILD_TOP"; value = ""; }