aboutsummaryrefslogtreecommitdiff
path: root/config/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/config.nix')
-rw-r--r--config/config.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/config/config.nix b/config/config.nix
index 0b57835..d6b4714 100644
--- a/config/config.nix
+++ b/config/config.nix
@@ -9,5 +9,22 @@
9 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"]; 9 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
10 extraOutputsToInstall = [ "bin" "man" "doc" "info" ]; 10 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
11 }; 11 };
12 # This adds header colors to the builds, but it rebuilds the whole
13 # world from scratch, so only use it to debug!
14 # add it as postHook in derivations
15 immaePostHook = ''
16 header() {
17 echo -ne "\033[1;36m"
18 echo -n "$1"
19 echo -e "\033[0m"
20 }
21
22 echoCmd() {
23 printf "\033[1;34m%s:\033[0m" "$1"
24 shift
25 printf ' %q' "$@"
26 echo
27 }
28 '';
12 }; 29 };
13} 30}