diff options
author | Ismaël Bouya <ismael.bouya@normalesup.org> | 2019-01-12 12:41:23 +0100 |
---|---|---|
committer | Ismaël Bouya <ismael.bouya@normalesup.org> | 2019-01-12 21:59:41 +0100 |
commit | 108891744eaa7410e305871212d5b81c1b67a095 (patch) | |
tree | 90e3f1a87573532ed1c14e233ad7348904ce47f8 /virtual/packages/infcloud.nix | |
parent | 950ca5ee979ae2467f3471216140de2c1d572f4b (diff) | |
download | Nix-108891744eaa7410e305871212d5b81c1b67a095.tar.gz Nix-108891744eaa7410e305871212d5b81c1b67a095.tar.zst Nix-108891744eaa7410e305871212d5b81c1b67a095.zip |
Refactor websites.
This commit refactors websites into module per "vhost".
Diffstat (limited to 'virtual/packages/infcloud.nix')
-rw-r--r-- | virtual/packages/infcloud.nix | 38 |
1 files changed, 0 insertions, 38 deletions
diff --git a/virtual/packages/infcloud.nix b/virtual/packages/infcloud.nix deleted file mode 100644 index 876578b..0000000 --- a/virtual/packages/infcloud.nix +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | { stdenv, fetchzip, ed }: | ||
2 | let | ||
3 | infcloud = rec { | ||
4 | webRoot = stdenv.mkDerivation rec { | ||
5 | version = "0.13.1"; | ||
6 | name = "InfCloud-${version}"; | ||
7 | src = fetchzip { | ||
8 | url = "https://www.inf-it.com/InfCloud_${version}.zip"; | ||
9 | sha256 = "1fjhs0cj0b9fhf5ysfz281mknmmg1z551bas143sxfcqlpa5aiiq"; | ||
10 | }; | ||
11 | buildPhase = '' | ||
12 | ./cache_update.sh | ||
13 | rm config.js | ||
14 | ''; | ||
15 | installPhase = '' | ||
16 | cp -a . $out | ||
17 | ln -s ${./infcloud_config.js} $out/config.js | ||
18 | ''; | ||
19 | buildInputs = [ ed ]; | ||
20 | }; | ||
21 | apache = { | ||
22 | user = "wwwrun"; | ||
23 | group = "wwwrun"; | ||
24 | vhostConf = '' | ||
25 | Alias /carddavmate ${webRoot} | ||
26 | Alias /caldavzap ${webRoot} | ||
27 | Alias /infcloud ${webRoot} | ||
28 | <Directory ${webRoot}> | ||
29 | AllowOverride All | ||
30 | Options FollowSymlinks | ||
31 | Require all granted | ||
32 | DirectoryIndex index.html | ||
33 | </Directory> | ||
34 | ''; | ||
35 | }; | ||
36 | }; | ||
37 | in | ||
38 | infcloud | ||