aboutsummaryrefslogtreecommitdiff
path: root/virtual/modules/websites/tellesflorian/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-01-13 15:47:56 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-01-13 15:51:36 +0100
commit2f0f1c487c914898528f49cde1b664312d0fbe23 (patch)
tree3b9009ad0061da0680c6293e7d581dfafc160b22 /virtual/modules/websites/tellesflorian/default.nix
parent35a397cd22e6c8dd7dec471f09416441b64deee4 (diff)
downloadNix-2f0f1c487c914898528f49cde1b664312d0fbe23.tar.gz
Nix-2f0f1c487c914898528f49cde1b664312d0fbe23.tar.zst
Nix-2f0f1c487c914898528f49cde1b664312d0fbe23.zip
Add Florian's website
Diffstat (limited to 'virtual/modules/websites/tellesflorian/default.nix')
-rw-r--r--virtual/modules/websites/tellesflorian/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/virtual/modules/websites/tellesflorian/default.nix b/virtual/modules/websites/tellesflorian/default.nix
new file mode 100644
index 0000000..8f8c35a
--- /dev/null
+++ b/virtual/modules/websites/tellesflorian/default.nix
@@ -0,0 +1,31 @@
1{ lib, pkgs, config, mylibs, ... }:
2let
3 adminer = pkgs.callPackage ../commons/adminer.nix {};
4
5 tellesflorian = pkgs.callPackage ./tellesflorian.nix { inherit (mylibs) checkEnv fetchedGitPrivate; };
6 tellesflorian_dev = tellesflorian { environment = "dev"; };
7
8 cfg = config.services.myWebsites.TellesFlorian;
9in {
10 options.services.myWebsites.TellesFlorian = {
11 integration = {
12 enable = lib.mkEnableOption "enable Florian Telles's website in integration";
13 };
14 };
15
16 config = lib.mkIf cfg.integration.enable {
17 security.acme.certs."eldiron".extraDomains."app.tellesflorian.com" = null;
18 services.myPhpfpm.poolConfigs.tellesflorian_dev = tellesflorian_dev.phpFpm.pool;
19 system.activationScripts.tellesflorian_dev = tellesflorian_dev.activationScript;
20 services.myWebsites.integration.modules = adminer.apache.modules ++ tellesflorian_dev.apache.modules;
21 services.myWebsites.integration.vhostConfs.tellesflorian = {
22 certName = "eldiron";
23 hosts = ["app.tellesflorian.com" ];
24 root = tellesflorian_dev.webRoot;
25 extraConfig = [
26 tellesflorian_dev.apache.vhostConf
27 adminer.apache.vhostConf
28 ];
29 };
30 };
31}