diff options
author | Ismaël Bouya <ismael.bouya@normalesup.org> | 2019-01-12 12:41:23 +0100 |
---|---|---|
committer | Ismaël Bouya <ismael.bouya@normalesup.org> | 2019-01-12 21:59:41 +0100 |
commit | 108891744eaa7410e305871212d5b81c1b67a095 (patch) | |
tree | 90e3f1a87573532ed1c14e233ad7348904ce47f8 /virtual/modules/gitweb/default.nix | |
parent | 950ca5ee979ae2467f3471216140de2c1d572f4b (diff) | |
download | Nix-108891744eaa7410e305871212d5b81c1b67a095.tar.gz Nix-108891744eaa7410e305871212d5b81c1b67a095.tar.zst Nix-108891744eaa7410e305871212d5b81c1b67a095.zip |
Refactor websites.
This commit refactors websites into module per "vhost".
Diffstat (limited to 'virtual/modules/gitweb/default.nix')
-rw-r--r-- | virtual/modules/gitweb/default.nix | 30 |
1 files changed, 0 insertions, 30 deletions
diff --git a/virtual/modules/gitweb/default.nix b/virtual/modules/gitweb/default.nix deleted file mode 100644 index 2a860ba..0000000 --- a/virtual/modules/gitweb/default.nix +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | { lib, pkgs, config, mylibs, ... }: | ||
2 | let | ||
3 | # FIXME: add buildbot | ||
4 | gitweb = pkgs.callPackage ./gitweb.nix { gitoliteDir = config.services.myGitolite.gitoliteDir; }; | ||
5 | cfg = config.services.myGitweb; | ||
6 | in { | ||
7 | options.services.myGitweb = { | ||
8 | enable = lib.mkEnableOption "my gitweb service"; | ||
9 | }; | ||
10 | |||
11 | config = lib.mkIf cfg.enable { | ||
12 | security.acme.certs."eldiron".extraDomains."git.immae.eu" = null; | ||
13 | |||
14 | nixpkgs.config.packageOverrides = oldpkgs: rec { | ||
15 | gitweb = oldpkgs.gitweb.overrideAttrs(old: { | ||
16 | installPhase = old.installPhase + '' | ||
17 | cp -r ${./theme} $out/gitweb-theme; | ||
18 | ''; | ||
19 | }); | ||
20 | }; | ||
21 | |||
22 | services.myWebsites.tools.modules = gitweb.apache.modules; | ||
23 | services.myWebsites.tools.vhostConfs.git = { | ||
24 | certName = "eldiron"; | ||
25 | hosts = ["git.immae.eu" ]; | ||
26 | root = gitweb.webRoot; | ||
27 | extraConfig = [ gitweb.apache.vhostConf ]; | ||
28 | }; | ||
29 | }; | ||
30 | } | ||