aboutsummaryrefslogtreecommitdiff
path: root/systems/eldiron/websites/tools/landing.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /systems/eldiron/websites/tools/landing.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'systems/eldiron/websites/tools/landing.nix')
-rw-r--r--systems/eldiron/websites/tools/landing.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/systems/eldiron/websites/tools/landing.nix b/systems/eldiron/websites/tools/landing.nix
new file mode 100644
index 0000000..f5d851e
--- /dev/null
+++ b/systems/eldiron/websites/tools/landing.nix
@@ -0,0 +1,38 @@
1{ stdenv, yarn2nix-moretea, nodejs_16 }:
2let
3 source = builtins.fetchGit {
4 url = "https://git.immae.eu/github/bastienwirtz/homer.git";
5 ref = "gitolite_local/local_changes";
6 rev = "bb60c5b869931f305f15c5bfa9cdb3f68702f01f";
7 narHash = "sha256-xBIBUJhQ7KPY0d92pW9ErA9OvGafWcxyuGkbHShF4Bs=";
8 };
9 yarnModules = yarn2nix-moretea.mkYarnModules rec {
10 nodejs = nodejs_16;
11 name = "landing";
12 pname = name;
13 version = "v1.0.0";
14 packageJSON = "${source}/package.json";
15 yarnLock = "${source}/yarn.lock";
16 yarnNix = ./landing/yarn-packages.nix;
17 };
18in
19 stdenv.mkDerivation rec {
20 pname = "landing";
21 version = "v1.0.0";
22 src = source;
23
24 buildInputs = [ yarnModules yarn2nix-moretea.yarn ];
25 configurePhase = ''
26 ln -s ${yarnModules}/node_modules .
27 '';
28 buildPhase = ''
29 # See https://stackoverflow.com/questions/74548318/how-to-resolve-error-error0308010cdigital-envelope-routinesunsupported-no
30 export NODE_OPTIONS=--openssl-legacy-provider
31 yarn build
32 '';
33 installPhase = ''
34 cp -a dist $out
35 cp ${./landing}/*.php $out/
36 ln -s service-worker.js $out/worker.js
37 '';
38 }