aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2021-01-28 00:15:47 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2021-01-28 13:49:34 +0100
commit0c506c055cb2fe42bcc92e905dc7996a75a66b7e (patch)
tree089c035607e518d0064453cfa397fea7550fa223 /shell.nix
parent86c40d69d72bd7085ee4e6108fa1dc6ff3be9184 (diff)
downloadNix-0c506c055cb2fe42bcc92e905dc7996a75a66b7e.tar.gz
Nix-0c506c055cb2fe42bcc92e905dc7996a75a66b7e.tar.zst
Nix-0c506c055cb2fe42bcc92e905dc7996a75a66b7e.zip
Update nix unstable
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix18
1 files changed, 16 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 93caa0b..3aa03a7 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,4 +1,18 @@
1{ pkgs ? import <nixpkgs> { overlays = builtins.attrValues (import ./overlays); } }: 1{ pkgs ? import <nixpkgs> { overlays = builtins.attrValues (import ./overlays); },
2 pkgs-nix ? import <nixpkgs-nix> { overlays = builtins.attrValues (import ./overlays); }
3}:
4let
5 patchedNix = pkgs-nix.nixUnstable.overrideAttrs(old: {
6 patches = old.patches ++ [
7 # Fix the ETag bug. PR merged. Remove when updating to >= 20210125
8 # https://github.com/NixOS/nixpkgs/pull/109309#issuecomment-768331750
9 (pkgs-nix.fetchpatch {
10 url = "https://patch-diff.githubusercontent.com/raw/NixOS/nix/pull/4470.diff";
11 sha256 = "sha256-d4RNOKMxa4NMbFgYcqWRv2ByHt8F/XUWV+6P9qHz7S4=";
12 })
13 ];
14 });
15in
2pkgs.mkShell { 16pkgs.mkShell {
3 buildInputs = [ pkgs.nixUnstable pkgs.morph pkgs.niv pkgs.pass pkgs.curl pkgs.shellcheck pkgs.jq pkgs.gnumake ]; 17 buildInputs = [ patchedNix pkgs.morph pkgs.niv pkgs.pass pkgs.curl pkgs.shellcheck pkgs.jq pkgs.gnumake ];
4} 18}