diff options
author | Ismaël Bouya <ismael.bouya@normalesup.org> | 2023-10-04 01:35:06 +0200 |
---|---|---|
committer | Ismaël Bouya <ismael.bouya@normalesup.org> | 2023-10-04 02:11:48 +0200 |
commit | 1a64deeb894dc95e2645a75771732c6cc53a79ad (patch) | |
tree | 1b9df4838f894577a09b9b260151756272efeb53 /pkgs/webapps/yourls | |
parent | fa25ffd4583cc362075cd5e1b4130f33306103f0 (diff) | |
download | Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip |
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them
contained personnal information about users. All thos changes got
stashed into a single commit (history is kept in a different place) and
private information was moved in a separate private repository
Diffstat (limited to 'pkgs/webapps/yourls')
-rw-r--r-- | pkgs/webapps/yourls/default.nix | 28 | ||||
-rw-r--r-- | pkgs/webapps/yourls/plugins/ldap/default.nix | 8 | ||||
-rw-r--r-- | pkgs/webapps/yourls/plugins/ldap/ldap.json | 15 | ||||
-rw-r--r-- | pkgs/webapps/yourls/yourls.json | 15 |
4 files changed, 0 insertions, 66 deletions
diff --git a/pkgs/webapps/yourls/default.nix b/pkgs/webapps/yourls/default.nix deleted file mode 100644 index d940c54..0000000 --- a/pkgs/webapps/yourls/default.nix +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | { yourls_config ? "/etc/yourls/config.php", mylibs, callPackage, lib, stdenv }: | ||
2 | let | ||
3 | pluginNames = [ "ldap" ]; | ||
4 | allPlugins = lib.attrsets.genAttrs pluginNames | ||
5 | (name: callPackage (./plugins + "/${name}") { inherit mylibs; }); | ||
6 | toPassthru = pkg: plugins: { | ||
7 | inherit plugins allPlugins; | ||
8 | withPlugins = withPlugins pkg; | ||
9 | }; | ||
10 | withPlugins = pkg: toPlugins: | ||
11 | let | ||
12 | plugins = toPlugins allPlugins; | ||
13 | toInstallPlugin = n: "ln -s ${n} $out/user/plugins/${n.pluginName}"; | ||
14 | newYourls = pkg.overrideAttrs(old: { | ||
15 | installPhase = old.installPhase + "\n" + builtins.concatStringsSep "\n" (map toInstallPlugin plugins); | ||
16 | passthru = toPassthru newYourls (pkg.plugins ++ plugins); | ||
17 | }); | ||
18 | in newYourls; | ||
19 | package = stdenv.mkDerivation (mylibs.fetchedGithub ./yourls.json // rec { | ||
20 | installPhase = '' | ||
21 | mkdir -p $out | ||
22 | cp -a */ *.php $out/ | ||
23 | cp sample-robots.txt $out/robots.txt | ||
24 | ln -sf ${yourls_config} $out/includes/config.php | ||
25 | ''; | ||
26 | passthru = toPassthru package []; | ||
27 | }); | ||
28 | in package | ||
diff --git a/pkgs/webapps/yourls/plugins/ldap/default.nix b/pkgs/webapps/yourls/plugins/ldap/default.nix deleted file mode 100644 index 01dc6fb..0000000 --- a/pkgs/webapps/yourls/plugins/ldap/default.nix +++ /dev/null | |||
@@ -1,8 +0,0 @@ | |||
1 | { stdenv, mylibs }: | ||
2 | stdenv.mkDerivation (mylibs.fetchedGithub ./ldap.json // rec { | ||
3 | installPhase = '' | ||
4 | mkdir -p $out | ||
5 | cp plugin.php $out | ||
6 | ''; | ||
7 | passthru.pluginName = "ldap"; | ||
8 | }) | ||
diff --git a/pkgs/webapps/yourls/plugins/ldap/ldap.json b/pkgs/webapps/yourls/plugins/ldap/ldap.json deleted file mode 100644 index 9411e4a..0000000 --- a/pkgs/webapps/yourls/plugins/ldap/ldap.json +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | { | ||
2 | "tag": "2a3cb03-master", | ||
3 | "meta": { | ||
4 | "name": "yourls-ldap-plugin", | ||
5 | "url": "https://github.com/k3a/yourls-ldap-plugin", | ||
6 | "branch": "master" | ||
7 | }, | ||
8 | "github": { | ||
9 | "owner": "k3a", | ||
10 | "repo": "yourls-ldap-plugin", | ||
11 | "rev": "2a3cb0334b8a6b81b284a7196e614bbd2b2b1615", | ||
12 | "sha256": "0cchbnli77d295lzf7kjmn4dcxj2bmdqa9qc3f8l8qgmp4n5n0gh", | ||
13 | "fetchSubmodules": true | ||
14 | } | ||
15 | } | ||
diff --git a/pkgs/webapps/yourls/yourls.json b/pkgs/webapps/yourls/yourls.json deleted file mode 100644 index 0a79b18..0000000 --- a/pkgs/webapps/yourls/yourls.json +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | { | ||
2 | "tag": "1.7.3", | ||
3 | "meta": { | ||
4 | "name": "yourls", | ||
5 | "url": "https://github.com/YOURLS/YOURLS", | ||
6 | "branch": "refs/tags/1.7.3" | ||
7 | }, | ||
8 | "github": { | ||
9 | "owner": "YOURLS", | ||
10 | "repo": "YOURLS", | ||
11 | "rev": "077018822d3594229daa8343310d0b40804b9ddc", | ||
12 | "sha256": "1av6h619rwqn0yn0kjn2s2h3gmrhmxaaa9hd5ns4ralxgg731imd", | ||
13 | "fetchSubmodules": true | ||
14 | } | ||
15 | } | ||