diff options
author | Ismaël Bouya <ismael.bouya@normalesup.org> | 2023-10-04 01:35:06 +0200 |
---|---|---|
committer | Ismaël Bouya <ismael.bouya@normalesup.org> | 2023-10-04 02:11:48 +0200 |
commit | 1a64deeb894dc95e2645a75771732c6cc53a79ad (patch) | |
tree | 1b9df4838f894577a09b9b260151756272efeb53 /pkgs/webapps/ttrss | |
parent | fa25ffd4583cc362075cd5e1b4130f33306103f0 (diff) | |
download | Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip |
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them
contained personnal information about users. All thos changes got
stashed into a single commit (history is kept in a different place) and
private information was moved in a separate private repository
Diffstat (limited to 'pkgs/webapps/ttrss')
13 files changed, 0 insertions, 184 deletions
diff --git a/pkgs/webapps/ttrss/default.nix b/pkgs/webapps/ttrss/default.nix deleted file mode 100644 index aeb573c..0000000 --- a/pkgs/webapps/ttrss/default.nix +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | { ttrss_config ? "/etc/ttrss/config.php" | ||
2 | , varDir ? "/var/lib/ttrss" | ||
3 | , stdenv, lib, callPackage, sources }: | ||
4 | let | ||
5 | pluginNames = [ "auth_ldap" "af_feedmod" "feediron" "ff_instagram" "tumblr_gdpr_ua" ]; | ||
6 | allPlugins = lib.attrsets.genAttrs pluginNames | ||
7 | (name: callPackage (./plugins + "/${name}") {}); | ||
8 | toPassthru = pkg: plugins: { | ||
9 | inherit plugins allPlugins; | ||
10 | withPlugins = withPlugins pkg; | ||
11 | }; | ||
12 | withPlugins = pkg: toPlugins: | ||
13 | let | ||
14 | plugins = toPlugins allPlugins; | ||
15 | toInstallPlugin = n: | ||
16 | "ln -sf ${n} $out/plugins/${n.pluginName}"; | ||
17 | newTtrss = pkg.overrideAttrs(old: { | ||
18 | installPhase = old.installPhase + "\n" + builtins.concatStringsSep "\n" (map toInstallPlugin plugins); | ||
19 | passthru = toPassthru newTtrss (pkg.plugins ++ plugins); | ||
20 | }); | ||
21 | in newTtrss; | ||
22 | package = stdenv.mkDerivation rec { | ||
23 | pname = "tt-rss"; | ||
24 | version = sources.webapps-ttrss.version; | ||
25 | name = "${pname}-${version}"; | ||
26 | src = sources.webapps-ttrss; | ||
27 | buildPhase = '' | ||
28 | rm -rf lock feed-icons cache | ||
29 | ln -sf ${varDir}/{lock,feed-icons,cache} . | ||
30 | ''; | ||
31 | installPhase = '' | ||
32 | cp -a . $out | ||
33 | ln -s ${ttrss_config} $out/config.php | ||
34 | ''; | ||
35 | passthru = toPassthru package []; | ||
36 | }; | ||
37 | in package | ||
diff --git a/pkgs/webapps/ttrss/plugins/af_feedmod/af_feedmod.json b/pkgs/webapps/ttrss/plugins/af_feedmod/af_feedmod.json deleted file mode 100644 index e57fcce..0000000 --- a/pkgs/webapps/ttrss/plugins/af_feedmod/af_feedmod.json +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | { | ||
2 | "tag": "0ea2092-master", | ||
3 | "meta": { | ||
4 | "name": "ttrss-af_feedmod", | ||
5 | "url": "https://github.com/mbirth/ttrss_plugin-af_feedmod", | ||
6 | "branch": "master" | ||
7 | }, | ||
8 | "github": { | ||
9 | "owner": "mbirth", | ||
10 | "repo": "ttrss_plugin-af_feedmod", | ||
11 | "rev": "0ea2092dd34067ecd898802cfca3570023d1ecfe", | ||
12 | "sha256": "02ibf47zcrsc2rr45wsix8gxyyf371davj8n8i0gj1zdq95klvnv", | ||
13 | "fetchSubmodules": true | ||
14 | } | ||
15 | } | ||
diff --git a/pkgs/webapps/ttrss/plugins/af_feedmod/default.nix b/pkgs/webapps/ttrss/plugins/af_feedmod/default.nix deleted file mode 100644 index 8512be3..0000000 --- a/pkgs/webapps/ttrss/plugins/af_feedmod/default.nix +++ /dev/null | |||
@@ -1,9 +0,0 @@ | |||
1 | { patched ? false, stdenv, mylibs, lib }: | ||
2 | stdenv.mkDerivation (mylibs.fetchedGithub ./af_feedmod.json // { | ||
3 | patches = lib.optionals patched [ ./type_replace.patch ]; | ||
4 | installPhase = '' | ||
5 | mkdir $out | ||
6 | cp init.php $out | ||
7 | ''; | ||
8 | passthru.pluginName = "af_feedmod"; | ||
9 | }) | ||
diff --git a/pkgs/webapps/ttrss/plugins/af_feedmod/type_replace.patch b/pkgs/webapps/ttrss/plugins/af_feedmod/type_replace.patch deleted file mode 100644 index d622577..0000000 --- a/pkgs/webapps/ttrss/plugins/af_feedmod/type_replace.patch +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | --- a/init.php 2014-06-16 14:21:06.995480038 +0200 | ||
2 | +++ b/init.php 2014-06-16 14:22:00.151027654 +0200 | ||
3 | @@ -147,6 +147,9 @@ | ||
4 | } | ||
5 | } | ||
6 | break; | ||
7 | + case 'replace': | ||
8 | + $article['content'] = preg_replace("/".$config['pattern']."/",$config['replacement'],$article['content']); | ||
9 | + break; | ||
10 | |||
11 | default: | ||
12 | // unknown type or invalid config | ||
diff --git a/pkgs/webapps/ttrss/plugins/auth_ldap/auth-ldap.json b/pkgs/webapps/ttrss/plugins/auth_ldap/auth-ldap.json deleted file mode 100644 index c8aaab5..0000000 --- a/pkgs/webapps/ttrss/plugins/auth_ldap/auth-ldap.json +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | { | ||
2 | "tag": "4d751b0-master", | ||
3 | "meta": { | ||
4 | "name": "ttrss-auth-ldap", | ||
5 | "url": "https://github.com/hydrian/TTRSS-Auth-LDAP", | ||
6 | "branch": "master" | ||
7 | }, | ||
8 | "github": { | ||
9 | "owner": "hydrian", | ||
10 | "repo": "TTRSS-Auth-LDAP", | ||
11 | "rev": "4d751b095c29a8dbe2dc7bb07777742956136e94", | ||
12 | "sha256": "0b9fl86acrzpcv41r7pj3bl8b3n72hpkdywzx9zjyfqv5pskxyim", | ||
13 | "fetchSubmodules": true | ||
14 | } | ||
15 | } | ||
diff --git a/pkgs/webapps/ttrss/plugins/auth_ldap/default.nix b/pkgs/webapps/ttrss/plugins/auth_ldap/default.nix deleted file mode 100644 index 424a9f7..0000000 --- a/pkgs/webapps/ttrss/plugins/auth_ldap/default.nix +++ /dev/null | |||
@@ -1,8 +0,0 @@ | |||
1 | { stdenv, mylibs }: | ||
2 | stdenv.mkDerivation (mylibs.fetchedGithub ./auth-ldap.json // { | ||
3 | installPhase = '' | ||
4 | mkdir $out | ||
5 | cp plugins/auth_ldap/init.php $out | ||
6 | ''; | ||
7 | passthru.pluginName = "auth_ldap"; | ||
8 | }) | ||
diff --git a/pkgs/webapps/ttrss/plugins/feediron/default.nix b/pkgs/webapps/ttrss/plugins/feediron/default.nix deleted file mode 100644 index 80bfda4..0000000 --- a/pkgs/webapps/ttrss/plugins/feediron/default.nix +++ /dev/null | |||
@@ -1,9 +0,0 @@ | |||
1 | { patched ? false, stdenv, mylibs, lib }: | ||
2 | stdenv.mkDerivation (mylibs.fetchedGithub ./feediron.json // { | ||
3 | patches = lib.optionals patched [ ./json_reformat.patch ]; | ||
4 | installPhase = '' | ||
5 | mkdir $out | ||
6 | cp -a . $out | ||
7 | ''; | ||
8 | passthru.pluginName = "feediron"; | ||
9 | }) | ||
diff --git a/pkgs/webapps/ttrss/plugins/feediron/feediron.json b/pkgs/webapps/ttrss/plugins/feediron/feediron.json deleted file mode 100644 index 5dbec92..0000000 --- a/pkgs/webapps/ttrss/plugins/feediron/feediron.json +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | { | ||
2 | "tag": "407168c-master", | ||
3 | "meta": { | ||
4 | "name": "ttrss-feediron", | ||
5 | "url": "https://github.com/m42e/ttrss_plugin-feediron", | ||
6 | "branch": "master" | ||
7 | }, | ||
8 | "github": { | ||
9 | "owner": "m42e", | ||
10 | "repo": "ttrss_plugin-feediron", | ||
11 | "rev": "407168c628880b5ced572cc549db6d50e866d3c8", | ||
12 | "sha256": "17b95ifpcph6m03hjd1mhi8gi1hw9yd3fnffmw66fqr5c9l3zd9r", | ||
13 | "fetchSubmodules": true | ||
14 | } | ||
15 | } | ||
diff --git a/pkgs/webapps/ttrss/plugins/feediron/json_reformat.patch b/pkgs/webapps/ttrss/plugins/feediron/json_reformat.patch deleted file mode 100644 index e1c44d9..0000000 --- a/pkgs/webapps/ttrss/plugins/feediron/json_reformat.patch +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | diff --git a/init.php b/init.php | ||
2 | index 3c0f2f9..1aad146 100644 | ||
3 | --- a/init.php | ||
4 | +++ b/init.php | ||
5 | @@ -600,10 +600,11 @@ class Feediron extends Plugin implements IHandler | ||
6 | return false; | ||
7 | } | ||
8 | |||
9 | - $this->host->set($this, 'json_conf', Feediron_Json::format($json_conf)); | ||
10 | + $new_conf = json_encode(json_decode($json_conf), JSON_PRETTY_PRINT); | ||
11 | + $this->host->set($this, 'json_conf', $new_conf); | ||
12 | $json_reply['success'] = true; | ||
13 | $json_reply['message'] = __('Configuration saved.'); | ||
14 | - $json_reply['json_conf'] = Feediron_Json::format($json_conf); | ||
15 | + $json_reply['json_conf'] = $new_conf; | ||
16 | echo json_encode($json_reply); | ||
17 | } | ||
18 | |||
diff --git a/pkgs/webapps/ttrss/plugins/ff_instagram/default.nix b/pkgs/webapps/ttrss/plugins/ff_instagram/default.nix deleted file mode 100644 index 3540f73..0000000 --- a/pkgs/webapps/ttrss/plugins/ff_instagram/default.nix +++ /dev/null | |||
@@ -1,8 +0,0 @@ | |||
1 | { stdenv, mylibs }: | ||
2 | stdenv.mkDerivation (mylibs.fetchedGithub ./ff_instagram.json // { | ||
3 | installPhase = '' | ||
4 | mkdir $out | ||
5 | cp -a . $out | ||
6 | ''; | ||
7 | passthru.pluginName = "ff_instagram"; | ||
8 | }) | ||
diff --git a/pkgs/webapps/ttrss/plugins/ff_instagram/ff_instagram.json b/pkgs/webapps/ttrss/plugins/ff_instagram/ff_instagram.json deleted file mode 100644 index 1f241b9..0000000 --- a/pkgs/webapps/ttrss/plugins/ff_instagram/ff_instagram.json +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | { | ||
2 | "tag": "0366ffb-master", | ||
3 | "meta": { | ||
4 | "name": "ttrss-ff_instagram", | ||
5 | "url": "https://github.com/wltb/ff_instagram", | ||
6 | "branch": "master" | ||
7 | }, | ||
8 | "github": { | ||
9 | "owner": "wltb", | ||
10 | "repo": "ff_instagram", | ||
11 | "rev": "0366ffb18c4d490c8fbfba2f5f3367a5af23cfe8", | ||
12 | "sha256": "0vvzl6wi6jmrqknsfddvckjgsgfizz1d923d1nyrpzjfn6bda1vk", | ||
13 | "fetchSubmodules": true | ||
14 | } | ||
15 | } | ||
diff --git a/pkgs/webapps/ttrss/plugins/tumblr_gdpr_ua/default.nix b/pkgs/webapps/ttrss/plugins/tumblr_gdpr_ua/default.nix deleted file mode 100644 index 2cf3e05..0000000 --- a/pkgs/webapps/ttrss/plugins/tumblr_gdpr_ua/default.nix +++ /dev/null | |||
@@ -1,8 +0,0 @@ | |||
1 | { stdenv, mylibs }: | ||
2 | stdenv.mkDerivation (mylibs.fetchedGithub ./tumblr_gdpr_ua.json // { | ||
3 | installPhase = '' | ||
4 | mkdir $out | ||
5 | cp -a . $out | ||
6 | ''; | ||
7 | passthru.pluginName = "tumblr_gdpr_ua"; | ||
8 | }) | ||
diff --git a/pkgs/webapps/ttrss/plugins/tumblr_gdpr_ua/tumblr_gdpr_ua.json b/pkgs/webapps/ttrss/plugins/tumblr_gdpr_ua/tumblr_gdpr_ua.json deleted file mode 100644 index eafbcfe..0000000 --- a/pkgs/webapps/ttrss/plugins/tumblr_gdpr_ua/tumblr_gdpr_ua.json +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | { | ||
2 | "tag": "287c584-master", | ||
3 | "meta": { | ||
4 | "name": "ttrss-tumblr_gdpr_ua", | ||
5 | "url": "https://github.com/hkockerbeck/ttrss-tumblr-gdpr-ua", | ||
6 | "branch": "master" | ||
7 | }, | ||
8 | "github": { | ||
9 | "owner": "hkockerbeck", | ||
10 | "repo": "ttrss-tumblr-gdpr-ua", | ||
11 | "rev": "287c584e68845d524f920156bff0b2eaa6f65117", | ||
12 | "sha256": "1fviawgcclqky4k4xv1sqzvpb8i74w9f0pclm09m78s8l85wh9py", | ||
13 | "fetchSubmodules": true | ||
14 | } | ||
15 | } | ||