aboutsummaryrefslogtreecommitdiff
path: root/pkgs/webapps/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2020-05-04 00:12:46 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2020-05-04 00:12:46 +0200
commit4b0a82cc2f4597a11b9275cf156ae9cceffaf44f (patch)
treea384ea0b7a610387f9a9cb8b6de4de58e8dd76b0 /pkgs/webapps/default.nix
parente9c91c19475ed679676829bfd716e41009b560c8 (diff)
downloadNix-4b0a82cc2f4597a11b9275cf156ae9cceffaf44f.tar.gz
Nix-4b0a82cc2f4597a11b9275cf156ae9cceffaf44f.tar.zst
Nix-4b0a82cc2f4597a11b9275cf156ae9cceffaf44f.zip
Fix some etherpad-lite modules and packaging
The upgrade to 1.8.3 broke many modules, which were patched to continue working correctly. This commit also reworks the module system, making it similar to python’s withPackages.
Diffstat (limited to 'pkgs/webapps/default.nix')
-rw-r--r--pkgs/webapps/default.nix17
1 files changed, 0 insertions, 17 deletions
diff --git a/pkgs/webapps/default.nix b/pkgs/webapps/default.nix
index 05172a9..fdf2651 100644
--- a/pkgs/webapps/default.nix
+++ b/pkgs/webapps/default.nix
@@ -15,23 +15,6 @@ rec {
15 (name: callPackage (./dokuwiki/plugins + "/${name}.nix") {}); 15 (name: callPackage (./dokuwiki/plugins + "/${name}.nix") {});
16 16
17 etherpad-lite = callPackage ./etherpad-lite {}; 17 etherpad-lite = callPackage ./etherpad-lite {};
18 etherpad-lite-with-modules = etherpad-lite.withModules (builtins.attrValues etherpad-lite-modules);
19 etherpad-lite-modules = let
20 nodeEnv = callPackage mylibs.nodeEnv {};
21 names = [
22 "ep_aa_file_menu_toolbar" "ep_adminpads" "ep_align" "ep_bookmark"
23 "ep_clear_formatting" "ep_colors" "ep_copy_paste_select_all"
24 "ep_cursortrace" "ep_embedmedia" "ep_font_family" "ep_font_size"
25 "ep_headings2" "ep_ldapauth" "ep_line_height" "ep_markdown"
26 "ep_previewimages" "ep_ruler" "ep_scrollto" "ep_set_title_on_pad"
27 "ep_subscript_and_superscript" "ep_timesliderdiff"
28 "ep_delete_empty_pads" "ep_mypads"
29 ];
30 in
31 # nix files are built using node2nix -i node-packages.json
32 lib.attrsets.genAttrs names
33 (name: (callPackage (./etherpad-lite/modules + "/${name}/node-packages.nix") { inherit nodeEnv; })
34 .${name}.overrideAttrs(old: { passthru = (old.passthru or {}) // { moduleName = name; }; }));
35 18
36 grocy = callPackage ./grocy { inherit mylibs composerEnv; }; 19 grocy = callPackage ./grocy { inherit mylibs composerEnv; };
37 20