aboutsummaryrefslogtreecommitdiff
path: root/pkgs/tiv
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-04-26 01:32:07 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-04-26 01:32:07 +0200
commit8c4f6e37479002818bcfe7381cd4e4b47fd2d1fb (patch)
tree8d032273fb3b5e4216b021795256e79dffe0b667 /pkgs/tiv
parentc79bb68270abd6e5a59e36bf09d64b2eb0d23fb8 (diff)
downloadNix-8c4f6e37479002818bcfe7381cd4e4b47fd2d1fb.tar.gz
Nix-8c4f6e37479002818bcfe7381cd4e4b47fd2d1fb.tar.zst
Nix-8c4f6e37479002818bcfe7381cd4e4b47fd2d1fb.zip
Start splitting nix environment to smaller files
Diffstat (limited to 'pkgs/tiv')
-rw-r--r--pkgs/tiv/default.nix19
-rw-r--r--pkgs/tiv/tiv_builder.sh8
2 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/tiv/default.nix b/pkgs/tiv/default.nix
new file mode 100644
index 0000000..c03aabe
--- /dev/null
+++ b/pkgs/tiv/default.nix
@@ -0,0 +1,19 @@
1{ buildPerlPackage, fetchurl, perlPackages }:
2buildPerlPackage rec {
3 name = "tiv-${version}";
4 version = "2015";
5 src = fetchurl {
6 url = "http://xyne.archlinux.ca/projects/tiv/src/tiv-${version}.tar.xz";
7 sha256 = "1vq073v7z7vmcd57lhs4rf4jasji69cpjgkz4dykp94a77p1qq90";
8 };
9
10 outputs = ["out"];
11 buildInputs = with perlPackages; [ PerlMagick ];
12 perlPreHookScript = ./tiv_builder.sh;
13 perlPreHook = ''
14 source $perlPreHookScript
15 '';
16 installPhase = ''
17 install -Dm755 tiv "$out/bin/tiv"
18 '';
19}
diff --git a/pkgs/tiv/tiv_builder.sh b/pkgs/tiv/tiv_builder.sh
new file mode 100644
index 0000000..ea16682
--- /dev/null
+++ b/pkgs/tiv/tiv_builder.sh
@@ -0,0 +1,8 @@
1orig=$(declare -f preConfigure)
2new_name="preConfigure2 ${orig#preConfigure}"
3eval "$new_name"
4
5preConfigure() {
6 preConfigure2 || true
7}
8