aboutsummaryrefslogtreecommitdiff
path: root/pkgs/pure-ftpd
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-05-02 03:02:53 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-05-02 03:02:53 +0200
commit6e2dc958bc8c5aac4871d2a618741fa4628ed126 (patch)
treea6dc7cfd70d06e6392c9a68fbf138fe88a0effdf /pkgs/pure-ftpd
parent851f25966e419564e2288c6dc675d0954da7e8cf (diff)
downloadNix-6e2dc958bc8c5aac4871d2a618741fa4628ed126.tar.gz
Nix-6e2dc958bc8c5aac4871d2a618741fa4628ed126.tar.zst
Nix-6e2dc958bc8c5aac4871d2a618741fa4628ed126.zip
Continue moving overlays to dedicated directory
Diffstat (limited to 'pkgs/pure-ftpd')
-rw-r--r--pkgs/pure-ftpd/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/pure-ftpd/default.nix b/pkgs/pure-ftpd/default.nix
new file mode 100644
index 0000000..37ce695
--- /dev/null
+++ b/pkgs/pure-ftpd/default.nix
@@ -0,0 +1,29 @@
1{ stdenv, fetchurl, openssl, postgresql, openldap }:
2
3stdenv.mkDerivation rec {
4 name = "pure-ftpd-1.0.47";
5
6 src = fetchurl {
7 url = "https://download.pureftpd.org/pub/pure-ftpd/releases/${name}.tar.gz";
8 sha256 = "1b97ixva8m10vln8xrfwwwzi344bkgxqji26d0nrm1yzylbc6h27";
9 };
10
11 preConfigure = ''
12 sed -i -e "s#FTPuid#immaeFtpUid#" src/log_ldap.h
13 sed -i -e "s#FTPgid#immaeFtpGid#" src/log_ldap.h
14 '';
15 postConfigure = ''
16 sed -i 's/define MAX_DATA_SIZE (40/define MAX_DATA_SIZE (70/' src/ftpd.h
17 '';
18 buildInputs = [ openssl postgresql openldap ];
19
20 configureFlags = [ "--with-everything" "--with-tls" "--with-pgsql" "--with-ldap" ];
21
22 meta = with stdenv.lib; {
23 description = "A free, secure, production-quality and standard-conformant FTP server";
24 homepage = https://www.pureftpd.org;
25 license = licenses.isc; # with some parts covered by BSD3(?)
26 maintainers = [ maintainers.lethalman ];
27 platforms = platforms.linux;
28 };
29}