aboutsummaryrefslogtreecommitdiff
path: root/pkgs/mtop
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-04-26 01:32:07 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-04-26 01:32:07 +0200
commit8c4f6e37479002818bcfe7381cd4e4b47fd2d1fb (patch)
tree8d032273fb3b5e4216b021795256e79dffe0b667 /pkgs/mtop
parentc79bb68270abd6e5a59e36bf09d64b2eb0d23fb8 (diff)
downloadNix-8c4f6e37479002818bcfe7381cd4e4b47fd2d1fb.tar.gz
Nix-8c4f6e37479002818bcfe7381cd4e4b47fd2d1fb.tar.zst
Nix-8c4f6e37479002818bcfe7381cd4e4b47fd2d1fb.zip
Start splitting nix environment to smaller files
Diffstat (limited to 'pkgs/mtop')
-rw-r--r--pkgs/mtop/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/mtop/default.nix b/pkgs/mtop/default.nix
new file mode 100644
index 0000000..4a89430
--- /dev/null
+++ b/pkgs/mtop/default.nix
@@ -0,0 +1,24 @@
1{ buildPerlPackage, fetchurl, perlPackages, lib }:
2buildPerlPackage rec {
3 name = "mtop-${version}";
4 version = "0.6.6";
5 src = fetchurl {
6 url = "http://downloads.sourceforge.net/project/mtop/mtop/v${version}/mtop-${version}.tar.gz";
7 sha256 = "0x0x5300b1j9i0xxk8rsrki0pspyzj2vylhzv8qg3l6j26aw0zrf";
8 };
9 outputs = ["out"];
10 buildInputs = with perlPackages; [ DBI DBDmysql Curses ];
11
12 postInstall = ''
13 cd "$out"
14 preConfigure || true
15 '';
16
17 meta = with lib; {
18 description = "MySQL top (monitor and examine slow queries)";
19 homepage = http://mtop.sourceforge.net/;
20 license = licenses.gpl3;
21 maintainers = with maintainers; [ { name = "Marc Prewitt"; email = "mprewitt@chelsea.net"; } ];
22 platforms = platforms.unix;
23 };
24}