aboutsummaryrefslogtreecommitdiff
path: root/pkgs/genius
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-04-26 12:12:12 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-04-26 12:12:12 +0200
commit98de2045a749b25d031b174c940096b4f5406b9d (patch)
tree3da1a45ec067551d233bb800eee912d44c5e7fdd /pkgs/genius
parenta2230e848bc85e484ef14163ac90fdb7045855f7 (diff)
downloadNix-98de2045a749b25d031b174c940096b4f5406b9d.tar.gz
Nix-98de2045a749b25d031b174c940096b4f5406b9d.tar.zst
Nix-98de2045a749b25d031b174c940096b4f5406b9d.zip
Move more packages to split files
Diffstat (limited to 'pkgs/genius')
-rw-r--r--pkgs/genius/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/pkgs/genius/default.nix b/pkgs/genius/default.nix
new file mode 100644
index 0000000..b40d1d0
--- /dev/null
+++ b/pkgs/genius/default.nix
@@ -0,0 +1,19 @@
1{ stdenv, fetchurl, mpfr, glib, hicolor-icon-theme, gtk2, intltool, gnome-doc-utils, python3, gnome2, autoconf, automake, libtool, ncurses, readline, pkg-config, }:
2stdenv.mkDerivation rec {
3 name = "genius-${version}";
4 version = "1.0.24";
5 src = fetchurl {
6 url = "https://download.gnome.org/sources/genius/1.0/${name}.tar.xz";
7 sha256 = "772f95f6ae4716d39bb180cd50e8b6b9b074107bee0cd083b825e1e6e55916b6";
8 };
9 buildInputs = [
10 mpfr glib hicolor-icon-theme gtk2 intltool gnome-doc-utils python3 gnome2.gtksourceview
11 autoconf automake libtool ncurses readline pkg-config
12 ];
13 preConfigure = ''
14 autoreconf -fi
15 '';
16 preBuild = ''
17 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
18 '';
19}