aboutsummaryrefslogtreecommitdiff
path: root/pkgs/dovecot
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-06-23 21:04:55 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-06-29 15:14:43 +0200
commita929614f94d11a4f397e72e74f38b3212c24cdee (patch)
treea81b3cee45586d685c1b7c6e5c39372f203aa00d /pkgs/dovecot
parent53fa9f9e7d87835d6137a029fe80b3195e635797 (diff)
downloadNix-a929614f94d11a4f397e72e74f38b3212c24cdee.tar.gz
Nix-a929614f94d11a4f397e72e74f38b3212c24cdee.tar.zst
Nix-a929614f94d11a4f397e72e74f38b3212c24cdee.zip
Configure mail (dovecot, postfix, spam checks)
Diffstat (limited to 'pkgs/dovecot')
-rw-r--r--pkgs/dovecot/plugins/deleted_to_trash/default.nix21
-rw-r--r--pkgs/dovecot/plugins/deleted_to_trash/dovecot-deleted_to_trash.json15
-rw-r--r--pkgs/dovecot/plugins/deleted_to_trash/fix_mbox.patch12
-rw-r--r--pkgs/dovecot/plugins/fts_xapian/default.nix14
-rw-r--r--pkgs/dovecot/plugins/fts_xapian/fts-xapian.json15
5 files changed, 77 insertions, 0 deletions
diff --git a/pkgs/dovecot/plugins/deleted_to_trash/default.nix b/pkgs/dovecot/plugins/deleted_to_trash/default.nix
new file mode 100644
index 0000000..db1afb5
--- /dev/null
+++ b/pkgs/dovecot/plugins/deleted_to_trash/default.nix
@@ -0,0 +1,21 @@
1{ stdenv, fetchurl, dovecot, mylibs, fetchpatch }:
2
3stdenv.mkDerivation (mylibs.fetchedGithub ./dovecot-deleted_to_trash.json // rec {
4 buildInputs = [ dovecot ];
5 patches = [
6 (fetchpatch {
7 name = "fix-dovecot-2.3.diff";
8 url = "https://github.com/lexbrugman/dovecot_deleted_to_trash/commit/c52a3799a96104a603ade33404ef6aa1db647b2f.diff";
9 sha256 = "0pld3rdcjp9df2qxbp807k6v4f48lyk0xy5q508ypa57d559y6dq";
10 })
11 ./fix_mbox.patch
12 ];
13 preConfigure = ''
14 substituteInPlace Makefile --replace \
15 "/usr/include/dovecot" \
16 "${dovecot}/include/dovecot"
17 substituteInPlace Makefile --replace \
18 "/usr/lib/dovecot/modules" \
19 "$out/lib/dovecot"
20 '';
21})
diff --git a/pkgs/dovecot/plugins/deleted_to_trash/dovecot-deleted_to_trash.json b/pkgs/dovecot/plugins/deleted_to_trash/dovecot-deleted_to_trash.json
new file mode 100644
index 0000000..2987a02
--- /dev/null
+++ b/pkgs/dovecot/plugins/deleted_to_trash/dovecot-deleted_to_trash.json
@@ -0,0 +1,15 @@
1{
2 "tag": "81b0754-master",
3 "meta": {
4 "name": "dovecot-deleted_to_trash",
5 "url": "https://github.com/lexbrugman/dovecot_deleted_to_trash",
6 "branch": "master"
7 },
8 "github": {
9 "owner": "lexbrugman",
10 "repo": "dovecot_deleted_to_trash",
11 "rev": "81b07549accfc36467bf8527a53c295c7a02dbb9",
12 "sha256": "1b3k31g898s4fa0a9l4kvjsdyds772waaay84sjdxv09jw6mqs0f",
13 "fetchSubmodules": true
14 }
15}
diff --git a/pkgs/dovecot/plugins/deleted_to_trash/fix_mbox.patch b/pkgs/dovecot/plugins/deleted_to_trash/fix_mbox.patch
new file mode 100644
index 0000000..0060fb4
--- /dev/null
+++ b/pkgs/dovecot/plugins/deleted_to_trash/fix_mbox.patch
@@ -0,0 +1,12 @@
1diff --git a/src/deleted-to-trash-plugin.c b/src/deleted-to-trash-plugin.c
2index bb4cc78..66bad53 100644
3--- a/src/deleted-to-trash-plugin.c
4+++ b/src/deleted-to-trash-plugin.c
5@@ -82,6 +82,7 @@ static struct mailbox *mailbox_open_or_create(struct mailbox_list *list, const c
6 *error_r = mail_storage_get_last_error(mailbox_get_storage(box), &error);
7 if (error != MAIL_ERROR_NOTFOUND)
8 {
9+ i_error("%s", *error_r);
10 mailbox_free(&box);
11 return NULL;
12 }
diff --git a/pkgs/dovecot/plugins/fts_xapian/default.nix b/pkgs/dovecot/plugins/fts_xapian/default.nix
new file mode 100644
index 0000000..350a3ff
--- /dev/null
+++ b/pkgs/dovecot/plugins/fts_xapian/default.nix
@@ -0,0 +1,14 @@
1{ stdenv, autoconf, automake, pkg-config, dovecot, libtool, xapian, icu, mylibs }:
2
3stdenv.mkDerivation (mylibs.fetchedGithub ./fts-xapian.json // rec {
4 buildInputs = [ dovecot autoconf automake libtool pkg-config xapian icu ];
5 preConfigure = ''
6 export PANDOC=false
7 autoreconf -vi
8 '';
9 configureFlags = [
10 "--with-dovecot=${dovecot}/lib/dovecot"
11 "--without-dovecot-install-dirs"
12 "--with-moduledir=$(out)/lib/dovecot"
13 ];
14})
diff --git a/pkgs/dovecot/plugins/fts_xapian/fts-xapian.json b/pkgs/dovecot/plugins/fts_xapian/fts-xapian.json
new file mode 100644
index 0000000..a786776
--- /dev/null
+++ b/pkgs/dovecot/plugins/fts_xapian/fts-xapian.json
@@ -0,0 +1,15 @@
1{
2 "tag": "9a94b4a-master",
3 "meta": {
4 "name": "fts-xapian",
5 "url": "https://github.com/grosjo/fts-xapian",
6 "branch": "master"
7 },
8 "github": {
9 "owner": "grosjo",
10 "repo": "fts-xapian",
11 "rev": "9a94b4aeaac3988786ad72a716127c306b05c9d6",
12 "sha256": "12xv5fnqahs0cy26ja2jwk6dg95626amblisf2wcx3nqzkcf4w1y",
13 "fetchSubmodules": true
14 }
15}