aboutsummaryrefslogtreecommitdiff
path: root/pkgs/crypto/cardano/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /pkgs/crypto/cardano/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'pkgs/crypto/cardano/default.nix')
-rw-r--r--pkgs/crypto/cardano/default.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/pkgs/crypto/cardano/default.nix b/pkgs/crypto/cardano/default.nix
deleted file mode 100644
index 879fddb..0000000
--- a/pkgs/crypto/cardano/default.nix
+++ /dev/null
@@ -1,29 +0,0 @@
1{ stdenv, mylibs }:
2let
3 daedalusSrc = (mylibs.fetchedGithub ./daedalus.json).src;
4 daedalusOrig = (import daedalusSrc {}).daedalus;
5 cfg = stdenv.mkDerivation rec {
6 name = "launcher-config-custom";
7 buildInputs = [ daedalusSrc daedalusOrig.cfg ];
8 src = daedalusOrig.cfg;
9 installPhase = ''
10 cp -a $src $out
11 chmod -R u+w $out
12 cd $out/etc
13 sed -e "/^walletPath/d" -e "/^walletArgs/d" launcher-config.yaml > launcher-config-server-only.yaml
14 '';
15 };
16in
17stdenv.mkDerivation rec {
18 name = "daedalus-custom";
19 src = daedalusOrig;
20 buildInputs = [ cfg daedalusOrig ];
21 installPhase = ''
22 cp -a $src $out
23 chmod -R u+w $out
24 cd $out/bin
25 sed -i -e "s@${builtins.storeDir}/[0-9a-z]*-daedalus-config@${cfg}/etc@" daedalus
26 sed -e "s@${cfg}/etc/launcher-config.yaml@${cfg}/etc/launcher-config-server-only.yaml@" daedalus > daedalus-server-only
27 chmod a+x daedalus-server-only
28 '';
29}