aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/websites/tools/tools/dokuwiki.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-05-07 00:01:09 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-05-07 00:01:09 +0200
commitc9d13ae319b4f01202a1afad046c3c1add1cc7ba (patch)
tree5552225ea95941d1273ce2b6e9e63884933f28ba /nixops/modules/websites/tools/tools/dokuwiki.nix
parentf61d1c7cb908ab83cffe962cc73f1a86e692b6e5 (diff)
downloadNix-c9d13ae319b4f01202a1afad046c3c1add1cc7ba.tar.gz
Nix-c9d13ae319b4f01202a1afad046c3c1add1cc7ba.tar.zst
Nix-c9d13ae319b4f01202a1afad046c3c1add1cc7ba.zip
Move dokuwiki to pkgs
Diffstat (limited to 'nixops/modules/websites/tools/tools/dokuwiki.nix')
-rw-r--r--nixops/modules/websites/tools/tools/dokuwiki.nix157
1 files changed, 58 insertions, 99 deletions
diff --git a/nixops/modules/websites/tools/tools/dokuwiki.nix b/nixops/modules/websites/tools/tools/dokuwiki.nix
index 2cd19f1..c61d15f 100644
--- a/nixops/modules/websites/tools/tools/dokuwiki.nix
+++ b/nixops/modules/websites/tools/tools/dokuwiki.nix
@@ -1,102 +1,61 @@
1{ lib, php, stdenv, writeText, fetchedGithub }: 1{ lib, stdenv, dokuwiki, dokuwiki-plugins }:
2let 2rec {
3 dokuwiki = let 3 varDir = "/var/lib/dokuwiki";
4 plugins = { 4 activationScript = {
5 farmer = stdenv.mkDerivation (fetchedGithub ./dokuwiki-plugin-farmer.json // rec { 5 deps = [ "wrappers" ];
6 installPhase = '' 6 text = ''
7 mkdir $out 7 if [ ! -d ${varDir} ]; then
8 cp -a * $out/ 8 install -m 0755 -o ${apache.user} -g ${apache.group} -d ${varDir} \
9 ''; 9 ${varDir}/animals
10 }); 10 cp -a ${webRoot}/conf.dist ${varDir}/conf
11 todo = stdenv.mkDerivation (fetchedGithub ./dokuwiki-plugin-todo.json // rec { 11 cp -a ${webRoot}/data.dist ${varDir}/data
12 installPhase = '' 12 cp -a ${webRoot}/
13 mkdir $out 13 chown -R ${apache.user}:${apache.user} ${varDir}/config ${varDir}/data
14 cp -a * $out/ 14 chmod -R 755 ${varDir}/config ${varDir}/data
15 ''; 15 fi
16 }); 16 install -m 0750 -o ${apache.user} -g ${apache.group} -d ${varDir}/phpSessions
17 }; 17 '';
18 preload = writeText "preload.php" '' 18 };
19 <?php 19 webRoot = dokuwiki.withPlugins (builtins.attrValues dokuwiki-plugins);
20 # farm setup by farmer plugin 20 apache = rec {
21 if(file_exists('${plugins.farmer}/DokuWikiFarmCore.php')) 21 user = "wwwrun";
22 { 22 group = "wwwrun";
23 include('${plugins.farmer}/DokuWikiFarmCore.php'); 23 modules = [ "proxy_fcgi" ];
24 } 24 webappName = "tools_dokuwiki";
25 ''; 25 root = "/run/current-system/webapps/${webappName}";
26 in rec { 26 vhostConf = ''
27 varDir = "/var/lib/dokuwiki"; 27 Alias /dokuwiki "${root}"
28 activationScript = { 28 <Directory "${root}">
29 deps = [ "wrappers" ]; 29 DirectoryIndex index.php
30 text = '' 30 <FilesMatch "\.php$">
31 if [ ! -d ${varDir} ]; then 31 SetHandler "proxy:unix:${phpFpm.socket}|fcgi://localhost"
32 install -m 0755 -o ${apache.user} -g ${apache.group} -d ${varDir} \ 32 </FilesMatch>
33 ${varDir}/animals
34 cp -a ${webRoot}/conf.dist ${varDir}/conf
35 cp -a ${webRoot}/data.dist ${varDir}/data
36 cp -a ${webRoot}/
37 chown -R ${apache.user}:${apache.user} ${varDir}/config ${varDir}/data
38 chmod -R 755 ${varDir}/config ${varDir}/data
39 fi
40 install -m 0750 -o ${apache.user} -g ${apache.group} -d ${varDir}/phpSessions
41 '';
42 };
43 webRoot = stdenv.mkDerivation (fetchedGithub ./dokuwiki.json // rec {
44 buildPhase = ''
45 mv conf conf.dist
46 mv data data.dist
47 '';
48 installPhase = ''
49 cp -a . $out
50 cp ${preload} $out/inc/preload.php
51 ln -sf ${varDir}/{conf,data} $out/
52 ln -sf ${varDir}/conf/.htaccess $out/
53 ${builtins.concatStringsSep "\n" (
54 lib.attrsets.mapAttrsToList (name: value: "ln -sf ${value} $out/lib/plugins/${name}") plugins
55 )}
56 '';
57 });
58 apache = rec {
59 user = "wwwrun";
60 group = "wwwrun";
61 modules = [ "proxy_fcgi" ];
62 webappName = "tools_dokuwiki";
63 root = "/run/current-system/webapps/${webappName}";
64 vhostConf = ''
65 Alias /dokuwiki "${root}"
66 <Directory "${root}">
67 DirectoryIndex index.php
68 <FilesMatch "\.php$">
69 SetHandler "proxy:unix:${phpFpm.socket}|fcgi://localhost"
70 </FilesMatch>
71 33
72 AllowOverride All 34 AllowOverride All
73 Options +FollowSymlinks 35 Options +FollowSymlinks
74 Require all granted 36 Require all granted
75 </Directory> 37 </Directory>
76 ''; 38 '';
77 }; 39 };
78 phpFpm = rec { 40 phpFpm = rec {
79 serviceDeps = [ "openldap.service" ]; 41 serviceDeps = [ "openldap.service" ];
80 basedir = builtins.concatStringsSep ":" ( 42 basedir = builtins.concatStringsSep ":" (
81 [ webRoot varDir ] 43 [ webRoot varDir ] ++ webRoot.plugins);
82 ++ lib.attrsets.mapAttrsToList (name: value: value) plugins); 44 socket = "/var/run/phpfpm/dokuwiki.sock";
83 socket = "/var/run/phpfpm/dokuwiki.sock"; 45 pool = ''
84 pool = '' 46 listen = ${socket}
85 listen = ${socket} 47 user = ${apache.user}
86 user = ${apache.user} 48 group = ${apache.group}
87 group = ${apache.group} 49 listen.owner = ${apache.user}
88 listen.owner = ${apache.user} 50 listen.group = ${apache.group}
89 listen.group = ${apache.group} 51 pm = ondemand
90 pm = ondemand 52 pm.max_children = 60
91 pm.max_children = 60 53 pm.process_idle_timeout = 60
92 pm.process_idle_timeout = 60
93 54
94 ; Needed to avoid clashes in browser cookies (same domain) 55 ; Needed to avoid clashes in browser cookies (same domain)
95 php_value[session.name] = DokuwikiPHPSESSID 56 php_value[session.name] = DokuwikiPHPSESSID
96 php_admin_value[open_basedir] = "${basedir}:/tmp" 57 php_admin_value[open_basedir] = "${basedir}:/tmp"
97 php_admin_value[session.save_path] = "${varDir}/phpSessions" 58 php_admin_value[session.save_path] = "${varDir}/phpSessions"
98 ''; 59 '';
99 };
100 }; 60 };
101in 61}
102 dokuwiki