aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/websites/apache/httpd_tools.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-04-14 19:24:39 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-04-14 19:24:39 +0200
commit62366a393e343b70571c6cf98ca74e94432b4f10 (patch)
tree34e3df630585d41e7858378987b9ca1f67786eec /nixops/modules/websites/apache/httpd_tools.nix
parent69475c58ebbb30ea72890133bf12aa0b2ccbd731 (diff)
downloadNix-62366a393e343b70571c6cf98ca74e94432b4f10.tar.gz
Nix-62366a393e343b70571c6cf98ca74e94432b4f10.tar.zst
Nix-62366a393e343b70571c6cf98ca74e94432b4f10.zip
Update http modules
Diffstat (limited to 'nixops/modules/websites/apache/httpd_tools.nix')
-rw-r--r--nixops/modules/websites/apache/httpd_tools.nix21
1 files changed, 18 insertions, 3 deletions
diff --git a/nixops/modules/websites/apache/httpd_tools.nix b/nixops/modules/websites/apache/httpd_tools.nix
index c0b779b..1b9d1e3 100644
--- a/nixops/modules/websites/apache/httpd_tools.nix
+++ b/nixops/modules/websites/apache/httpd_tools.nix
@@ -187,8 +187,8 @@ let
187 SSLRandomSeed startup builtin 187 SSLRandomSeed startup builtin
188 SSLRandomSeed connect builtin 188 SSLRandomSeed connect builtin
189 189
190 SSLProtocol All -SSLv2 -SSLv3 190 SSLProtocol ${mainCfg.sslProtocols}
191 SSLCipherSuite HIGH:!aNULL:!MD5:!EXP 191 SSLCipherSuite ${mainCfg.sslCiphers}
192 SSLHonorCipherOrder on 192 SSLHonorCipherOrder on
193 ''; 193 '';
194 194
@@ -217,7 +217,7 @@ let
217 ) null ([ cfg ] ++ subservices); 217 ) null ([ cfg ] ++ subservices);
218 218
219 documentRoot = if maybeDocumentRoot != null then maybeDocumentRoot else 219 documentRoot = if maybeDocumentRoot != null then maybeDocumentRoot else
220 pkgs.runCommand "empty" {} "mkdir -p $out"; 220 pkgs.runCommand "empty" { preferLocalBuild = true; } "mkdir -p $out";
221 221
222 documentRootConf = '' 222 documentRootConf = ''
223 DocumentRoot "${documentRoot}" 223 DocumentRoot "${documentRoot}"
@@ -376,6 +376,8 @@ let
376 Include ${httpd}/conf/extra/httpd-multilang-errordoc.conf 376 Include ${httpd}/conf/extra/httpd-multilang-errordoc.conf
377 Include ${httpd}/conf/extra/httpd-languages.conf 377 Include ${httpd}/conf/extra/httpd-languages.conf
378 378
379 TraceEnable off
380
379 ${if enableSSL then sslConf else ""} 381 ${if enableSSL then sslConf else ""}
380 382
381 # Fascist default - deny access to everything. 383 # Fascist default - deny access to everything.
@@ -623,6 +625,19 @@ in
623 description = 625 description =
624 "Maximum number of httpd requests answered per httpd child (prefork), 0 means unlimited"; 626 "Maximum number of httpd requests answered per httpd child (prefork), 0 means unlimited";
625 }; 627 };
628
629 sslCiphers = mkOption {
630 type = types.str;
631 default = "HIGH:!aNULL:!MD5:!EXP";
632 description = "Cipher Suite available for negotiation in SSL proxy handshake.";
633 };
634
635 sslProtocols = mkOption {
636 type = types.str;
637 default = "All -SSLv2 -SSLv3 -TLSv1";
638 example = "All -SSLv2 -SSLv3";
639 description = "Allowed SSL/TLS protocol versions.";
640 };
626 } 641 }
627 642
628 # Include the options shared between the main server and virtual hosts. 643 # Include the options shared between the main server and virtual hosts.