aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/mpd/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-04-25 02:18:59 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-04-25 02:18:59 +0200
commit742697c95318d3625298437995e948ee00a00ba5 (patch)
tree322bba0294512d71011efa15b84ef0c2134900a3 /nixops/modules/mpd/default.nix
parentccdd91a78b1a6ae757db20d757ba8674dd25e0cc (diff)
downloadNix-742697c95318d3625298437995e948ee00a00ba5.tar.gz
Nix-742697c95318d3625298437995e948ee00a00ba5.tar.zst
Nix-742697c95318d3625298437995e948ee00a00ba5.zip
Move ssh ftp and mpd to new secrets
Diffstat (limited to 'nixops/modules/mpd/default.nix')
-rw-r--r--nixops/modules/mpd/default.nix16
1 files changed, 9 insertions, 7 deletions
diff --git a/nixops/modules/mpd/default.nix b/nixops/modules/mpd/default.nix
index 2cf37ad..0904732 100644
--- a/nixops/modules/mpd/default.nix
+++ b/nixops/modules/mpd/default.nix
@@ -4,20 +4,22 @@
4 nixpkgs.overlays = [ (self: super: rec { 4 nixpkgs.overlays = [ (self: super: rec {
5 mpd = (self.callPackage ./mpd.nix {}).mpd; 5 mpd = (self.callPackage ./mpd.nix {}).mpd;
6 }) ]; 6 }) ];
7 deployment.keys = { 7 mySecrets.keys = [
8 mpd = { 8 {
9 dest = "mpd";
9 permissions = "0400"; 10 permissions = "0400";
10 text = myconfig.env.mpd.password; 11 text = myconfig.env.mpd.password;
11 }; 12 }
12 mpd-config = { 13 {
14 dest = "mpd-config";
13 permissions = "0400"; 15 permissions = "0400";
14 user = "mpd"; 16 user = "mpd";
15 group = "mpd"; 17 group = "mpd";
16 text = '' 18 text = ''
17 password "${myconfig.env.mpd.password}@read,add,control,admin" 19 password "${myconfig.env.mpd.password}@read,add,control,admin"
18 ''; 20 '';
19 }; 21 }
20 }; 22 ];
21 networking.firewall.allowedTCPPorts = [ 6600 ]; 23 networking.firewall.allowedTCPPorts = [ 6600 ];
22 users.users.mpd.extraGroups = [ "wwwrun" "keys" ]; 24 users.users.mpd.extraGroups = [ "wwwrun" "keys" ];
23 system.activationScripts.mpd = '' 25 system.activationScripts.mpd = ''
@@ -28,7 +30,7 @@
28 network.listenAddress = "any"; 30 network.listenAddress = "any";
29 musicDirectory = myconfig.env.mpd.folder; 31 musicDirectory = myconfig.env.mpd.folder;
30 extraConfig = '' 32 extraConfig = ''
31 include "/run/keys/mpd-config" 33 include "/var/secrets/mpd-config"
32 audio_output { 34 audio_output {
33 type "null" 35 type "null"
34 name "No Output" 36 name "No Output"