aboutsummaryrefslogtreecommitdiff
path: root/modules/secrets.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-06-02 09:48:05 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-06-02 11:23:54 +0200
commit717ccfd957e686d773480df817387aebbe79aa48 (patch)
treeb2f59c57da32dcafefee9ccc5d7e6d32e498721e /modules/secrets.nix
parent29f8cb850d74b456d6481a456311bbf5361d328c (diff)
downloadNix-717ccfd957e686d773480df817387aebbe79aa48.tar.gz
Nix-717ccfd957e686d773480df817387aebbe79aa48.tar.zst
Nix-717ccfd957e686d773480df817387aebbe79aa48.zip
Finish moving aten php configuration to dedicated module
Diffstat (limited to 'modules/secrets.nix')
-rw-r--r--modules/secrets.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/modules/secrets.nix b/modules/secrets.nix
index 808b15c..a2424e9 100644
--- a/modules/secrets.nix
+++ b/modules/secrets.nix
@@ -11,7 +11,16 @@
11 default = "/var/secrets"; 11 default = "/var/secrets";
12 description = "Location where to put the keys"; 12 description = "Location where to put the keys";
13 }; 13 };
14 # Read-only variables
15 fullPaths = lib.mkOption {
16 type = lib.types.attrsOf lib.types.path;
17 default = builtins.listToAttrs
18 (map (v: { name = v.dest; value = "${config.secrets.location}/${v.dest}"; }) config.secrets.keys);
19 readOnly = true;
20 description = "set of full paths to secrets";
21 };
14 }; 22 };
23
15 config = let 24 config = let
16 location = config.secrets.location; 25 location = config.secrets.location;
17 keys = config.secrets.keys; 26 keys = config.secrets.keys;