aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/tools/tools/landing.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /modules/private/websites/tools/tools/landing.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'modules/private/websites/tools/tools/landing.nix')
-rw-r--r--modules/private/websites/tools/tools/landing.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/modules/private/websites/tools/tools/landing.nix b/modules/private/websites/tools/tools/landing.nix
deleted file mode 100644
index 2acc323..0000000
--- a/modules/private/websites/tools/tools/landing.nix
+++ /dev/null
@@ -1,29 +0,0 @@
1{ sources, stdenv, yarn2nix-moretea }:
2let
3 yarnModules = yarn2nix-moretea.mkYarnModules rec {
4 name = "landing";
5 pname = name;
6 version = "v1.0.0";
7 packageJSON = "${sources.webapps-landing}/package.json";
8 yarnLock = "${sources.webapps-landing}/yarn.lock";
9 yarnNix = ./landing/yarn-packages.nix;
10 };
11in
12 stdenv.mkDerivation rec {
13 pname = "landing";
14 version = "v1.0.0";
15 src = sources.webapps-landing;
16
17 buildInputs = [ yarnModules yarn2nix-moretea.yarn ];
18 configurePhase = ''
19 ln -s ${yarnModules}/node_modules .
20 '';
21 buildPhase = ''
22 yarn build
23 '';
24 installPhase = ''
25 cp -a dist $out
26 cp ${./landing}/*.php $out/
27 ln -s service-worker.js $out/worker.js
28 '';
29 }