aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/tools/peertube/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2020-04-10 14:54:48 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2020-04-10 14:54:48 +0200
commit3c408c981aa73c856b983035fab6e82ac143cc04 (patch)
treedfa0c0a49755b750c40ea2b9cddcef863bdc2862 /modules/private/websites/tools/peertube/default.nix
parent9f16e659f129dd8acab7d086ef9822673a01ba06 (diff)
downloadNix-3c408c981aa73c856b983035fab6e82ac143cc04.tar.gz
Nix-3c408c981aa73c856b983035fab6e82ac143cc04.tar.zst
Nix-3c408c981aa73c856b983035fab6e82ac143cc04.zip
Fix peertube default configuration
Diffstat (limited to 'modules/private/websites/tools/peertube/default.nix')
-rw-r--r--modules/private/websites/tools/peertube/default.nix159
1 files changed, 0 insertions, 159 deletions
diff --git a/modules/private/websites/tools/peertube/default.nix b/modules/private/websites/tools/peertube/default.nix
index 445030c..3345453 100644
--- a/modules/private/websites/tools/peertube/default.nix
+++ b/modules/private/websites/tools/peertube/default.nix
@@ -32,25 +32,6 @@ in {
32 https: true 32 https: true
33 hostname: 'peertube.immae.eu' 33 hostname: 'peertube.immae.eu'
34 port: 443 34 port: 443
35 rates_limit:
36 api:
37 # 50 attempts in 10 seconds
38 window: 10 seconds
39 max: 50
40 login:
41 # 15 attempts in 5 min
42 window: 5 minutes
43 max: 15
44 signup:
45 # 2 attempts in 5 min (only succeeded attempts are taken into account)
46 window: 5 minutes
47 max: 2
48 ask_send_email:
49 # 3 attempts in 5 min
50 window: 5 minutes
51 max: 3
52 trust_proxy:
53 - 'loopback'
54 database: 35 database:
55 hostname: '${env.postgresql.socket}' 36 hostname: '${env.postgresql.socket}'
56 port: 5432 37 port: 5432
@@ -78,19 +59,7 @@ in {
78 smtp: 59 smtp:
79 transport: sendmail 60 transport: sendmail
80 sendmail: '/run/wrappers/bin/sendmail' 61 sendmail: '/run/wrappers/bin/sendmail'
81 hostname: null
82 port: 465 # If you use StartTLS: 587
83 username: null
84 password: null
85 tls: true # If you use StartTLS: false
86 disable_starttls: false
87 ca_file: null # Used for self signed certificates
88 from_address: 'peertube@tools.immae.eu' 62 from_address: 'peertube@tools.immae.eu'
89 email:
90 body:
91 signature: "PeerTube"
92 subject:
93 prefix: "[PeerTube]"
94 storage: 63 storage:
95 tmp: '${pcfg.dataDir}/storage/tmp/' 64 tmp: '${pcfg.dataDir}/storage/tmp/'
96 avatars: '${pcfg.dataDir}/storage/avatars/' 65 avatars: '${pcfg.dataDir}/storage/avatars/'
@@ -104,134 +73,6 @@ in {
104 captions: '${pcfg.dataDir}/storage/captions/' 73 captions: '${pcfg.dataDir}/storage/captions/'
105 cache: '${pcfg.dataDir}/storage/cache/' 74 cache: '${pcfg.dataDir}/storage/cache/'
106 plugins: '${pcfg.dataDir}/storage/plugins/' 75 plugins: '${pcfg.dataDir}/storage/plugins/'
107 log:
108 level: 'info'
109 rotation:
110 enabled : true # Enabled by default, if disabled make sure that 'storage.logs' is pointing to a folder handled by logrotate
111 maxFileSize: 12MB
112 maxFiles: 20
113 anonymizeIP: false
114 search:
115 remote_uri:
116 users: true
117 anonymous: false
118 trending:
119 videos:
120 interval_days: 7
121 redundancy:
122 videos:
123 check_interval: '1 hour' # How often you want to check new videos to cache
124 strategies: # Just uncomment strategies you want
125 csp:
126 enabled: false
127 report_only: true # CSP directives are still being tested, so disable the report only mode at your own risk!
128 report_uri:
129 tracker:
130 enabled: true
131 private: true
132 reject_too_many_announces: false
133 history:
134 videos:
135 max_age: -1
136 views:
137 videos:
138 remote:
139 max_age: -1
140 plugins:
141 index:
142 enabled: true
143 check_latest_versions_interval: '12 hours'
144 url: 'https://packages.joinpeertube.org'
145 # Following are saved in local-production.json
146 cache:
147 previews:
148 size: 500 # Max number of previews you want to cache
149 captions:
150 size: 500 # Max number of video captions/subtitles you want to cache
151 admin:
152 email: 'peertube@tools.immae.eu'
153 contact_form:
154 enabled: true
155 signup:
156 enabled: false
157 limit: 10
158 requires_email_verification: false
159 filters:
160 cidr:
161 whitelist: []
162 blacklist: []
163 user:
164 video_quota: -1
165 video_quota_daily: -1
166 transcoding:
167 enabled: false
168 allow_additional_extensions: true
169 allow_audio_files: true
170 threads: 1
171 resolutions:
172 0p: false
173 240p: false
174 360p: false
175 480p: true
176 720p: true
177 1080p: true
178 2160p: false
179 webtorrent:
180 enabled: true
181 hls:
182 enabled: false
183 import:
184 videos:
185 http:
186 enabled: true
187 torrent:
188 enabled: false
189 auto_blacklist:
190 videos:
191 of_users:
192 enabled: false
193 instance:
194 name: 'Immae&#x2019;s PeerTube'
195 short_description: 'PeerTube, a federated (ActivityPub) video streaming platform using P2P (BitTorrent) directly in the web browser with WebTorrent and Angular.'
196 description: '''
197 terms: '''
198 code_of_conduct: '''
199 moderation_information: '''
200 creation_reason: '''
201 administrator: '''
202 maintenance_lifetime: '''
203 business_model: '''
204 hardware_information: '''
205 languages:
206 categories:
207 default_client_route: '/videos/trending'
208 is_nsfw: false
209 default_nsfw_policy: 'do_not_list'
210 customizations:
211 javascript: '''
212 css: '''
213 robots: |
214 User-agent: *
215 Disallow:
216 securitytxt:
217 "# If you would like to report a security issue\n# you may report it to:\nContact: https://github.com/Chocobozzz/PeerTube/blob/develop/SECURITY.md\nContact: mailto:"
218 services:
219 twitter:
220 username: '@_immae'
221 whitelisted: false
222 followers:
223 instance:
224 enabled: true
225 manual_approval: false
226 followings:
227 instance:
228 auto_follow_back:
229 enabled: false
230 auto_follow_index:
231 enabled: false
232 index_url: 'https://instances.joinpeertube.org'
233 theme:
234 default: 'default'
235 ''; 76 '';
236 }]; 77 }];
237 78