aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/tools/mastodon/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-06-01 00:01:46 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-06-01 00:01:46 +0200
commit17f6eae9907a122d4472da727ae8b1ac1c40c027 (patch)
tree133ab8877a47ec707cb8c96e561a29e45395fce6 /modules/private/websites/tools/mastodon/default.nix
parentf33aade75160a345a721fd60451b9edaa4d10e44 (diff)
downloadNix-17f6eae9907a122d4472da727ae8b1ac1c40c027.tar.gz
Nix-17f6eae9907a122d4472da727ae8b1ac1c40c027.tar.zst
Nix-17f6eae9907a122d4472da727ae8b1ac1c40c027.zip
Add a filesWatcher service to restart them when secrets change
Diffstat (limited to 'modules/private/websites/tools/mastodon/default.nix')
-rw-r--r--modules/private/websites/tools/mastodon/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/modules/private/websites/tools/mastodon/default.nix b/modules/private/websites/tools/mastodon/default.nix
index d742a33..1a4b387 100644
--- a/modules/private/websites/tools/mastodon/default.nix
+++ b/modules/private/websites/tools/mastodon/default.nix
@@ -63,6 +63,19 @@ in {
63 socketsPrefix = "live_immae"; 63 socketsPrefix = "live_immae";
64 dataDir = "/var/lib/mastodon_immae"; 64 dataDir = "/var/lib/mastodon_immae";
65 }; 65 };
66 services.filesWatcher.mastodon-streaming = {
67 restart = true;
68 paths = [ mcfg.configFile ];
69 };
70 services.filesWatcher.mastodon-web = {
71 restart = true;
72 paths = [ mcfg.configFile ];
73 };
74 services.filesWatcher.mastodon-sidekiq = {
75 restart = true;
76 paths = [ mcfg.configFile ];
77 };
78
66 79
67 services.websites.tools.modules = [ 80 services.websites.tools.modules = [
68 "headers" "proxy" "proxy_wstunnel" "proxy_http" 81 "headers" "proxy" "proxy_wstunnel" "proxy_http"