aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/tools/db/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /modules/private/websites/tools/db/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'modules/private/websites/tools/db/default.nix')
-rw-r--r--modules/private/websites/tools/db/default.nix21
1 files changed, 0 insertions, 21 deletions
diff --git a/modules/private/websites/tools/db/default.nix b/modules/private/websites/tools/db/default.nix
deleted file mode 100644
index fc8d989..0000000
--- a/modules/private/websites/tools/db/default.nix
+++ /dev/null
@@ -1,21 +0,0 @@
1{ lib, pkgs, config, ... }:
2let
3 adminer = pkgs.callPackage ../../commons/adminer.nix { inherit config; };
4
5 cfg = config.myServices.websites.tools.db;
6in {
7 options.myServices.websites.tools.db = {
8 enable = lib.mkEnableOption "enable database's website";
9 };
10
11 config = lib.mkIf cfg.enable {
12 services.websites.env.tools.modules = adminer.apache.modules;
13 services.websites.env.tools.vhostConfs.db-1 = {
14 certName = "eldiron";
15 addToCerts = true;
16 hosts = ["db-1.immae.eu" ];
17 root = null;
18 extraConfig = [ (adminer.apache.vhostConf null) ];
19 };
20 };
21}