aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/piedsjaloux/app/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /modules/private/websites/piedsjaloux/app/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'modules/private/websites/piedsjaloux/app/default.nix')
-rw-r--r--modules/private/websites/piedsjaloux/app/default.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/modules/private/websites/piedsjaloux/app/default.nix b/modules/private/websites/piedsjaloux/app/default.nix
deleted file mode 100644
index 4525a18..0000000
--- a/modules/private/websites/piedsjaloux/app/default.nix
+++ /dev/null
@@ -1,29 +0,0 @@
1{ environment, varDir, secretsPath
2, composerEnv, fetchurl, fetchgit, sources }:
3let
4 app = composerEnv.buildPackage (
5 import ./php-packages.nix { inherit composerEnv fetchurl fetchgit; } //
6 rec {
7 version = sources.websites-piedsjaloux-app.version;
8 pname = "piedsjaloux";
9 name = "${pname}-${version}";
10 src = sources.websites-piedsjaloux-app;
11 noDev = (environment == "prod");
12 preInstall = ''
13 export SYMFONY_ENV="${environment}"
14 '';
15 # /!\ miniatures and data need to be in the same physical dir due to a
16 # bug in leapt.im (searches for data/../miniatures)
17 postInstall = ''
18 cd $out
19 rm app/config/parameters.yml
20 ln -sf ${secretsPath} app/config/parameters.yml
21 rm -rf var/{logs,cache,data,miniatures,tmp}
22 ln -sf ${varDir}/{logs,cache,data,miniatures,tmp} var/
23 '';
24 passthru = {
25 inherit varDir environment secretsPath;
26 webRoot = "${app}/web";
27 };
28 });
29in app