aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/denise/production.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2020-06-15 00:39:03 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2020-06-15 00:39:03 +0200
commita295d69fcfabe64bd17ae05f1948505531ea99a2 (patch)
tree1d7e06f4f3e7219b160af3af9681262b42e8ff31 /modules/private/websites/denise/production.nix
parentce7d09efb55888501b73f9e763811deac762aed2 (diff)
downloadNix-a295d69fcfabe64bd17ae05f1948505531ea99a2.tar.gz
Nix-a295d69fcfabe64bd17ae05f1948505531ea99a2.tar.zst
Nix-a295d69fcfabe64bd17ae05f1948505531ea99a2.zip
Add Denise websites
Diffstat (limited to 'modules/private/websites/denise/production.nix')
-rw-r--r--modules/private/websites/denise/production.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/modules/private/websites/denise/production.nix b/modules/private/websites/denise/production.nix
new file mode 100644
index 0000000..9b28e9e
--- /dev/null
+++ b/modules/private/websites/denise/production.nix
@@ -0,0 +1,25 @@
1{ lib, config, pkgs, ... }:
2let
3 cfg = config.myServices.websites.denise.production;
4in {
5 options.myServices.websites.denise.production.enable = lib.mkEnableOption "enable Denise's website";
6
7 config = lib.mkIf cfg.enable {
8 services.websites.env.production.vhostConfs.denise_production = {
9 certName = "denise";
10 addToCerts = true;
11 hosts = [ "syanni.eu" "www.syanni.eu" ];
12 root = ../_www;
13 extraConfig = [
14 ''
15 <Directory ${../_www}>
16 DirectoryIndex index.htm index.html
17 Options Indexes FollowSymLinks MultiViews Includes
18 AllowOverride AuthConfig
19 Require all granted
20 </Directory>
21 ''
22 ];
23 };
24 };
25}