aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/cip-ca/sympa.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /modules/private/websites/cip-ca/sympa.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'modules/private/websites/cip-ca/sympa.nix')
-rw-r--r--modules/private/websites/cip-ca/sympa.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/modules/private/websites/cip-ca/sympa.nix b/modules/private/websites/cip-ca/sympa.nix
deleted file mode 100644
index bb66fc6..0000000
--- a/modules/private/websites/cip-ca/sympa.nix
+++ /dev/null
@@ -1,28 +0,0 @@
1{ lib, config, ... }:
2let
3 cfg = config.myServices.websites.cip-ca.sympa;
4in
5{
6 options.myServices.websites.cip-ca.sympa.enable = lib.mkEnableOption "enable cip-ca’s sympa website";
7 config = lib.mkIf cfg.enable {
8 services.websites.env.tools.vhostConfs.cipca_sympa = {
9 certName = "cip-ca";
10 certMainHost = "mail.cip-ca.fr";
11 hosts = [ "mail.cip-ca.fr" ];
12 root = null;
13 extraConfig = [
14 ''
15 Alias /static-sympa/ /var/lib/sympa/static_content/
16 <Directory /var/lib/sympa/static_content/>
17 Require all granted
18 AllowOverride none
19 </Directory>
20 <Location /sympa>
21 SetHandler "proxy:unix:/run/sympa/wwsympa.socket|fcgi://"
22 Require all granted
23 </Location>
24 ''
25 ];
26 };
27 };
28}