aboutsummaryrefslogtreecommitdiff
path: root/modules/private/system/backup-2.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-10-18 19:43:39 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-10-18 19:43:39 +0200
commit8415083eb6acc343dfa404dbbc12fa0171a48a20 (patch)
treed83f54c99763ae49076bf3071449595b6ccae133 /modules/private/system/backup-2.nix
parent8fa7ff2c63fb0722144bc90837512d9f8b8c929d (diff)
downloadNix-8415083eb6acc343dfa404dbbc12fa0171a48a20.tar.gz
Nix-8415083eb6acc343dfa404dbbc12fa0171a48a20.tar.zst
Nix-8415083eb6acc343dfa404dbbc12fa0171a48a20.zip
Add new machine to nixops
Diffstat (limited to 'modules/private/system/backup-2.nix')
-rw-r--r--modules/private/system/backup-2.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/modules/private/system/backup-2.nix b/modules/private/system/backup-2.nix
new file mode 100644
index 0000000..c67eab6
--- /dev/null
+++ b/modules/private/system/backup-2.nix
@@ -0,0 +1,24 @@
1{ privateFiles }:
2{ config, pkgs, myconfig, ... }:
3{
4 boot.kernelPackages = pkgs.linuxPackages_latest;
5 _module.args.privateFiles = privateFiles;
6 imports = builtins.attrValues (import ../..);
7
8 deployment = {
9 targetEnv = "hetznerCloud";
10 hetznerCloud = {
11 authToken = myconfig.env.hetznerCloud.authToken;
12 datacenter = "hel1-dc2";
13 location ="hel1";
14 serverType = "cx11";
15 };
16 };
17
18 # This value determines the NixOS release with which your system is
19 # to be compatible, in order to avoid breaking some software such as
20 # database servers. You should change this only after NixOS release
21 # notes say you should.
22 # https://nixos.org/nixos/manual/release-notes.html
23 system.stateVersion = "19.03"; # Did you read the comment?
24}