aboutsummaryrefslogtreecommitdiff
path: root/modules/private/monitoring/to_objects.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2020-01-05 17:08:32 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2020-01-05 17:08:32 +0100
commite820134d38c3b7470ea5112f40a6dc967f039878 (patch)
treef05a5cefe285d060aa0ebf52829bcfcd35549f8b /modules/private/monitoring/to_objects.nix
parentb22ce4895ef1e9723a02061f7293e528cfbf9754 (diff)
downloadNix-e820134d38c3b7470ea5112f40a6dc967f039878.tar.gz
Nix-e820134d38c3b7470ea5112f40a6dc967f039878.tar.zst
Nix-e820134d38c3b7470ea5112f40a6dc967f039878.zip
Add monitoring host
Diffstat (limited to 'modules/private/monitoring/to_objects.nix')
-rw-r--r--modules/private/monitoring/to_objects.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/modules/private/monitoring/to_objects.nix b/modules/private/monitoring/to_objects.nix
index 5ad76e0..7b4b523 100644
--- a/modules/private/monitoring/to_objects.nix
+++ b/modules/private/monitoring/to_objects.nix
@@ -17,7 +17,7 @@ let
17 define service { 17 define service {
18 ${builtins.concatStringsSep "\n" (mapAttrsToList (k: v: 18 ${builtins.concatStringsSep "\n" (mapAttrsToList (k: v:
19 " ${pad 30 k} ${toStr k v}" 19 " ${pad 30 k} ${toStr k v}"
20 ) service)} 20 ) (filterAttrs (k: v: ! builtins.elem k ["passiveInfo" "filter"]) service))}
21 } 21 }
22 ''; 22 '';
23 toServices = services: builtins.concatStringsSep "\n" (map toService services); 23 toServices = services: builtins.concatStringsSep "\n" (map toService services);
@@ -59,7 +59,7 @@ let
59 then toCommands v 59 then toCommands v
60 else if keyname == "templates" 60 else if keyname == "templates"
61 then toTemplates v 61 then toTemplates v
62 else if builtins.elem keyname ["host" "contactgroup" "contact" "timeperiod"] 62 else if builtins.elem keyname ["hostgroup" "host" "contactgroup" "contact" "timeperiod" "servicegroup"]
63 then toOthers keyname v 63 then toOthers keyname v
64 else ""; 64 else "";
65 toObjects = v: builtins.concatStringsSep "\n" (mapAttrsToList toObjects' v); 65 toObjects = v: builtins.concatStringsSep "\n" (mapAttrsToList toObjects' v);