aboutsummaryrefslogtreecommitdiff
path: root/modules/private/loginctl-linger.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2020-02-04 08:29:52 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2020-02-04 08:29:52 +0100
commit7f2863538c4d5f9c08a9a4c0353b7f95f609351b (patch)
tree4ab15e438411febf8b2ab512f3a07dc18bed2dc5 /modules/private/loginctl-linger.nix
parentd12fe9403bb104f32893c003ab3be1a0a946db96 (diff)
downloadNix-7f2863538c4d5f9c08a9a4c0353b7f95f609351b.tar.gz
Nix-7f2863538c4d5f9c08a9a4c0353b7f95f609351b.tar.zst
Nix-7f2863538c4d5f9c08a9a4c0353b7f95f609351b.zip
Add loginctl module
Diffstat (limited to 'modules/private/loginctl-linger.nix')
-rw-r--r--modules/private/loginctl-linger.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/modules/private/loginctl-linger.nix b/modules/private/loginctl-linger.nix
new file mode 100644
index 0000000..e6b9f23
--- /dev/null
+++ b/modules/private/loginctl-linger.nix
@@ -0,0 +1,47 @@
1{ config, lib, pkgs, ... }:
2
3# https://github.com/michalrus/dotfiles/commit/ebd5fa9583f82589f23531647aa677feb3f8d344#diff-4d353005ef5b3e37f33c07332b8523edR1
4# A temporary hack to `loginctl enable-linger $somebody` (for
5# multiplexer sessions to last), until this one is unresolved:
6# https://github.com/NixOS/nixpkgs/issues/3702
7#
8# Usage: `users.extraUsers.somebody.linger = true` or slt.
9
10with lib;
11
12let
13
14 dataDir = "/var/lib/systemd/linger";
15
16 lingeringUsers = map (u: u.name) (attrValues (flip filterAttrs config.users.users (n: u: u.linger)));
17
18 lingeringUsersFile = builtins.toFile "lingering-users"
19 (concatStrings (map (s: "${s}\n")
20 (sort (a: b: a < b) lingeringUsers))); # this sorting is important for `comm` to work correctly
21
22 updateLingering = pkgs.writeScript "update-lingering" ''
23 if [ ! -e ${dataDir} ]; then
24 install -m 0755 -o root -g root -d ${dataDir}
25 fi
26 if [ -e ${dataDir} ] ; then
27 ls ${dataDir} | sort | comm -3 -1 ${lingeringUsersFile} - | xargs -r ${pkgs.systemd}/bin/loginctl disable-linger
28 ls ${dataDir} | sort | comm -3 -2 ${lingeringUsersFile} - | xargs -r ${pkgs.systemd}/bin/loginctl enable-linger
29 fi
30 '';
31
32in
33
34{
35 options = {
36 users.users = mkOption {
37 options = [{
38 linger = mkEnableOption "lingering for the user";
39 }];
40 };
41 };
42
43 config = {
44 system.activationScripts.update-lingering =
45 stringAfter [ "users" ] updateLingering;
46 };
47}