aboutsummaryrefslogtreecommitdiff
path: root/modules/private/gemini/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /modules/private/gemini/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'modules/private/gemini/default.nix')
-rw-r--r--modules/private/gemini/default.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/modules/private/gemini/default.nix b/modules/private/gemini/default.nix
deleted file mode 100644
index ffe8a12..0000000
--- a/modules/private/gemini/default.nix
+++ /dev/null
@@ -1,26 +0,0 @@
1{ lib, config, pkgs, ... }:
2let
3 configFile = pkgs.writeText "config.yaml" ''
4 listen: ":1965"
5 hosts:
6 immae.eu:
7 cert: /var/lib/acme/immae/full.pem
8 key: /var/lib/acme/immae/key.pem
9 paths:
10 - path: /
11 root: ${./public}
12 '';
13in
14{
15 options.myServices.gemini.enable = lib.mkEnableOption "enable Gemini capsule";
16 config = lib.mkIf config.myServices.gemini.enable {
17 networking.firewall.allowedTCPPorts = [ 1965 ];
18 systemd.services.gemini = {
19 description = "Gemini capsule server";
20 wantedBy = [ "multi-user.target" ];
21 after = [ "network.target" ];
22 serviceConfig.ExecStart = "${pkgs.twins}/bin/twins -config ${configFile}";
23 serviceConfig.Type = "simple";
24 };
25 };
26}