aboutsummaryrefslogtreecommitdiff
path: root/modules/private/environment.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2021-05-01 21:07:09 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2021-05-01 21:07:09 +0200
commit8175055f973b3f6e8a383abcaa42afb22f279e24 (patch)
tree7d154e5b3de0825694dd103c6ec3080dd5721cbb /modules/private/environment.nix
parenta0e80453478719b9b13240f0e045d4d0419b8109 (diff)
downloadNix-8175055f973b3f6e8a383abcaa42afb22f279e24.tar.gz
Nix-8175055f973b3f6e8a383abcaa42afb22f279e24.tar.zst
Nix-8175055f973b3f6e8a383abcaa42afb22f279e24.zip
Add keys handling for bind9
Diffstat (limited to 'modules/private/environment.nix')
-rw-r--r--modules/private/environment.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/modules/private/environment.nix b/modules/private/environment.nix
index 9cd591e..32af339 100644
--- a/modules/private/environment.nix
+++ b/modules/private/environment.nix
@@ -384,6 +384,16 @@ in
384 }; 384 };
385 type = attrsOf (attrsOf (listOf str)); 385 type = attrsOf (attrsOf (listOf str));
386 }; 386 };
387 keys = mkOption {
388 default = {};
389 description = "DNS keys";
390 type = attrsOf (submodule {
391 options = {
392 algorithm = mkOption { type = str; description = "Algorithm"; };
393 secret = mkOption { type = str; description = "Secret"; };
394 };
395 });
396 };
387 slaveZones = mkOption { 397 slaveZones = mkOption {
388 description = "List of slave zones"; 398 description = "List of slave zones";
389 type = listOf (submodule { 399 type = listOf (submodule {
@@ -393,6 +403,11 @@ in
393 description = "NS master groups of this zone"; 403 description = "NS master groups of this zone";
394 type = listOf str; 404 type = listOf str;
395 }; 405 };
406 keys = mkOption {
407 default = [];
408 description = "Keys associated to the server";
409 type = listOf str;
410 };
396 }; 411 };
397 }); 412 });
398 }; 413 };