aboutsummaryrefslogtreecommitdiff
path: root/modules/private/environment.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2020-01-17 01:15:04 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2020-01-17 01:15:04 +0100
commit71a2425ed95120a6de3a41bb233b1066779d4c26 (patch)
tree007f2756abab644604577352da28b1fd4c20df44 /modules/private/environment.nix
parent981fa80354fd6f00f49446777c38f77bd8a65f65 (diff)
downloadNix-71a2425ed95120a6de3a41bb233b1066779d4c26.tar.gz
Nix-71a2425ed95120a6de3a41bb233b1066779d4c26.tar.zst
Nix-71a2425ed95120a6de3a41bb233b1066779d4c26.zip
Add e-mail checks monitoring
Diffstat (limited to 'modules/private/environment.nix')
-rw-r--r--modules/private/environment.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/modules/private/environment.nix b/modules/private/environment.nix
index 81b5df5..7da2480 100644
--- a/modules/private/environment.nix
+++ b/modules/private/environment.nix
@@ -486,6 +486,19 @@ in
486 slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; }; 486 slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
487 slack_channel = mkOption { type = str; description = "Slack channel to push status update"; }; 487 slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };
488 contacts = mkOption { type = attrsOf unspecified; description = "Contact dicts to fill naemon objects"; }; 488 contacts = mkOption { type = attrsOf unspecified; description = "Contact dicts to fill naemon objects"; };
489 email_check = mkOption {
490 description = "Emails services to check";
491 type = attrsOf (submodule {
492 options = {
493 local = mkOption { type = bool; default = false; description = "Use local configuration"; };
494 port = mkOption { type = nullOr str; default = null; description = "Port to connect to ssh"; };
495 login = mkOption { type = nullOr str; default = null; description = "Login to connect to ssh"; };
496 targets = mkOption { type = listOf str; description = "Hosts to send E-mails to"; };
497 mail_address = mkOption { type = str; description = "E-mail recipient part to send e-mail to"; };
498 mail_domain = mkOption { type = str; description = "E-mail domain part to send e-mail to"; };
499 };
500 });
501 };
489 }; 502 };
490 }; 503 };
491 }; 504 };