aboutsummaryrefslogtreecommitdiff
path: root/modules/private/environment.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2020-07-16 01:10:17 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2020-07-16 01:10:17 +0200
commit5a61f6ad5164a735be26e016c59e72252ffb49b7 (patch)
tree6acc3c8199d7f25c039c6c6686005436d1fb49d7 /modules/private/environment.nix
parentca367c14902ab1bf869976dc5dca52d07e308c15 (diff)
downloadNix-5a61f6ad5164a735be26e016c59e72252ffb49b7.tar.gz
Nix-5a61f6ad5164a735be26e016c59e72252ffb49b7.tar.zst
Nix-5a61f6ad5164a735be26e016c59e72252ffb49b7.zip
Add alternate cloud storage for daily backups
Diffstat (limited to 'modules/private/environment.nix')
-rw-r--r--modules/private/environment.nix21
1 files changed, 18 insertions, 3 deletions
diff --git a/modules/private/environment.nix b/modules/private/environment.nix
index b8c4dd2..069a344 100644
--- a/modules/private/environment.nix
+++ b/modules/private/environment.nix
@@ -441,9 +441,24 @@ in
441 type = submodule { 441 type = submodule {
442 options = { 442 options = {
443 password = mkOption { type = str; description = "Password for encrypting files"; }; 443 password = mkOption { type = str; description = "Password for encrypting files"; };
444 remote = mkOption { type = str; description = "Remote url access"; }; 444 remotes = mkOption {
445 accessKeyId = mkOption { type = str; description = "Remote access-key"; }; 445 type = attrsOf (submodule {
446 secretAccessKey = mkOption { type = str; description = "Remote access secret"; }; 446 options = {
447 remote = mkOption {
448 type = unspecified;
449 example = literalExample ''
450 bucket: "s3://some_host/${bucket}";
451 '';
452 description = ''
453 Function.
454 Takes a bucket name as argument and returns a url
455 '';
456 };
457 accessKeyId = mkOption { type = str; description = "Remote access-key"; };
458 secretAccessKey = mkOption { type = str; description = "Remote access secret"; };
459 };
460 });
461 };
447 }; 462 };
448 }; 463 };
449 }; 464 };