aboutsummaryrefslogtreecommitdiff
path: root/flakes/taskwarrior-web/flake.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/taskwarrior-web/flake.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/taskwarrior-web/flake.nix')
-rw-r--r--flakes/taskwarrior-web/flake.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/flakes/taskwarrior-web/flake.nix b/flakes/taskwarrior-web/flake.nix
new file mode 100644
index 0000000..b08290a
--- /dev/null
+++ b/flakes/taskwarrior-web/flake.nix
@@ -0,0 +1,33 @@
1{
2 description = "A web interface for the Taskwarrior todo application. Because being a neckbeard is only fun sometimes.";
3 inputs.flake-utils.url = "github:numtide/flake-utils";
4 inputs.nixpkgs = {
5 url = "github:NixOS/nixpkgs/840c782d507d60aaa49aa9e3f6d0b0e780912742";
6 flake = false;
7 };
8 inputs.taskwarrior-web = {
9 url = "github:theunraveler/taskwarrior-web/a79cfe2b42791b62364118e58b21b892fff6ded8";
10 flake = false;
11 };
12
13 outputs = { self, nixpkgs, taskwarrior-web, flake-utils }: flake-utils.lib.eachSystem ["x86_64-linux"] (system:
14 let
15 pkgs = import nixpkgs { inherit system; overlays = []; };
16 inherit (pkgs) callPackage;
17 in rec {
18 packages.taskwarrior-web = callPackage ./. { src = taskwarrior-web; };
19 defaultPackage = packages.taskwarrior-web;
20 legacyPackages.taskwarrior-web = packages.taskwarrior-web;
21 checks = {
22 build = defaultPackage;
23 };
24 }
25 ) // rec {
26 overlays = {
27 taskwarrior-web = final: prev: {
28 taskwarrior-web = self.defaultPackage."${final.system}";
29 };
30 };
31 overlay = overlays.taskwarrior-web;
32 };
33}