aboutsummaryrefslogtreecommitdiff
path: root/flakes/private/php/flake.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/private/php/flake.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/private/php/flake.nix')
-rw-r--r--flakes/private/php/flake.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/flakes/private/php/flake.nix b/flakes/private/php/flake.nix
new file mode 100644
index 0000000..a730b68
--- /dev/null
+++ b/flakes/private/php/flake.nix
@@ -0,0 +1,40 @@
1{
2 description = "Php old versions";
3 inputs.flake-utils.url = "github:numtide/flake-utils";
4 inputs.nixpkgs = {
5 url = "github:NixOS/nixpkgs/840c782d507d60aaa49aa9e3f6d0b0e780912742";
6 flake = false;
7 };
8 inputs.nixpkgs-4 = {
9 url = "github:NixOS/nixpkgs/062a0c5437b68f950b081bbfc8a699d57a4ee026";
10 flake = false;
11 };
12 outputs = { self, nixpkgs, nixpkgs-4, flake-utils }: flake-utils.lib.eachSystem ["x86_64-linux"] (system:
13 let
14 pkgs = import nixpkgs { inherit system; overlays = []; };
15 in rec {
16 packages = {
17 php72 = pkgs.php72;
18 php73 = pkgs.php73;
19 php74 = (import nixpkgs-4 { inherit system; overlays = []; }).php74;
20 cryptpad = (import nixpkgs-4 { inherit system; overlays = []; }).cryptpad;
21 python37 = (import nixpkgs-4 { inherit system; overlays = []; }).python37;
22 python37Packages = (import nixpkgs-4 { inherit system; overlays = []; }).python37Packages;
23 telegram-purple = (import nixpkgs-4 { inherit system; overlays = []; }).telegram-purple;
24 };
25 defaultPackage = packages.php73;
26 legacyPackages = packages;
27 }) // rec {
28 overlays = {
29 php = final: prev: {
30 php72 = self.packages."${final.system}".php72;
31 php73 = self.packages."${final.system}".php73;
32 php74 = self.packages."${final.system}".php74;
33 cryptpad = self.packages."${final.system}".cryptpad;
34 python37 = self.packages."${final.system}".python37;
35 telegram-purple = self.packages."${final.system}".telegram-purple;
36 };
37 };
38 overlay = overlays.php;
39 };
40}