aboutsummaryrefslogtreecommitdiff
path: root/flakes/private/paste/flake.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/private/paste/flake.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/private/paste/flake.nix')
-rw-r--r--flakes/private/paste/flake.nix36
1 files changed, 13 insertions, 23 deletions
diff --git a/flakes/private/paste/flake.nix b/flakes/private/paste/flake.nix
index 23f8cd3..97853ea 100644
--- a/flakes/private/paste/flake.nix
+++ b/flakes/private/paste/flake.nix
@@ -1,30 +1,20 @@
1{ 1{
2 inputs.paste = { 2 inputs.paste.url = "path:../../paste";
3 path = "../../paste";
4 type = "path";
5 };
6 inputs.my-lib = {
7 path = "../../lib";
8 type = "path";
9 };
10 inputs.nix-lib.url = "github:NixOS/nixpkgs";
11 3
12 description = "Private configuration for paste"; 4 description = "Private configuration for paste";
13 outputs = { self, my-lib, nix-lib, paste }: 5 outputs = { self, paste }: {
14 let 6 nixosModule = self.nixosModules.paste;
15 cfg = name': { config, lib, pkgs, name, ... }: { 7 nixosModules.paste = { ... }: {
16 imports = [ 8 imports = [
17 (my-lib.lib.withNarKey paste "nixosModule") 9 paste.nixosModule
18 ]; 10 ];
19 config = lib.mkIf (name == name') { 11 config = {
20 services.paste = { 12 services.paste = {
21 enable = true; 13 enable = true;
22 webDirectory = "/paste"; 14 webDirectory = "/paste";
23 };
24 }; 15 };
25 }; 16 };
26 in 17 };
27 paste.outputs // 18 };
28 { nixosModules = paste.nixosModules or {} // nix-lib.lib.genAttrs ["eldiron"] cfg; };
29} 19}
30 20