aboutsummaryrefslogtreecommitdiff
path: root/flakes/peertube/flake.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/peertube/flake.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/peertube/flake.nix')
-rw-r--r--flakes/peertube/flake.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/flakes/peertube/flake.nix b/flakes/peertube/flake.nix
index 2f9c8c1..e8153eb 100644
--- a/flakes/peertube/flake.nix
+++ b/flakes/peertube/flake.nix
@@ -1,9 +1,7 @@
1{ 1{
2 description = "A free software to take back control of your videos"; 2 description = "A free software to take back control of your videos";
3 inputs.myuids = { 3 inputs.myuids = {
4 url = "https://git.immae.eu/perso/Immae/Config/Nix.git"; 4 url = "path:../myuids";
5 type = "git";
6 dir = "flakes/myuids";
7 }; 5 };
8 inputs.flake-utils.url = "github:numtide/flake-utils"; 6 inputs.flake-utils.url = "github:numtide/flake-utils";
9 inputs.nixpkgs.url = "github:NixOS/nixpkgs"; 7 inputs.nixpkgs.url = "github:NixOS/nixpkgs";
@@ -166,10 +164,10 @@
166 nixosModule = { lib, pkgs, config, ... }: 164 nixosModule = { lib, pkgs, config, ... }:
167 let 165 let
168 name = "peertube"; 166 name = "peertube";
169 cfg = config.services.peertube; 167 cfg = config.immaeServices.peertube;
170 in 168 in
171 { 169 {
172 options.services.peertube = { 170 options.immaeServices.peertube = {
173 enable = lib.mkEnableOption "Enable Peertube’s service"; 171 enable = lib.mkEnableOption "Enable Peertube’s service";
174 user = lib.mkOption { 172 user = lib.mkOption {
175 type = lib.types.str; 173 type = lib.types.str;
@@ -239,6 +237,8 @@
239 237
240 environment.NODE_CONFIG_DIR = "${cfg.dataDir}/config"; 238 environment.NODE_CONFIG_DIR = "${cfg.dataDir}/config";
241 environment.NODE_ENV = "production"; 239 environment.NODE_ENV = "production";
240 environment.NPM_CONFIG_LOGS_DIR = "${cfg.dataDir}/npm_logs";
241 environment.NPM_CONFIG_CACHE = "${cfg.dataDir}/npm_cache";
242 environment.HOME = cfg.package; 242 environment.HOME = cfg.package;
243 243
244 path = [ pkgs.nodejs pkgs.yarn pkgs.bashInteractive pkgs.ffmpeg pkgs.openssl ]; 244 path = [ pkgs.nodejs pkgs.yarn pkgs.bashInteractive pkgs.ffmpeg pkgs.openssl ];