aboutsummaryrefslogtreecommitdiff
path: root/flakes/openarc/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2021-08-23 01:50:09 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2021-08-24 00:49:51 +0200
commit5e2ec9fb8628136e7f9f618c68c0e42ab086b80e (patch)
treeee56ee4a49b7d48fc91e7baf34ca0158f9c64cff /flakes/openarc/default.nix
parentdfe02d8fd52e33c7d4e1a209cf486696100b88f3 (diff)
downloadNix-5e2ec9fb8628136e7f9f618c68c0e42ab086b80e.tar.gz
Nix-5e2ec9fb8628136e7f9f618c68c0e42ab086b80e.tar.zst
Nix-5e2ec9fb8628136e7f9f618c68c0e42ab086b80e.zip
Refactor flakes using follows
Diffstat (limited to 'flakes/openarc/default.nix')
-rw-r--r--flakes/openarc/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/flakes/openarc/default.nix b/flakes/openarc/default.nix
new file mode 100644
index 0000000..c6d74c6
--- /dev/null
+++ b/flakes/openarc/default.nix
@@ -0,0 +1,20 @@
1{ stdenv, automake, autoconf, libbsd, libtool, openssl, pkg-config, libmilter, file, lib, src }:
2stdenv.mkDerivation rec {
3 pname = "openarc";
4 version = "master-${src.shortRev or "unknown"}";
5 inherit src;
6 buildInputs = [ automake autoconf libbsd libtool openssl pkg-config libmilter ];
7
8 configureFlags = [
9 "--with-milter=${libmilter}"
10 ];
11 preConfigure = ''
12 autoreconf --force --install
13 sed -i -e "s@/usr/bin/file@${file}/bin/file@" ./configure
14 '';
15 meta = {
16 description = "Open source ARC implementation";
17 homepage = "https://github.com/trusteddomainproject/OpenARC";
18 platforms = lib.platforms.unix;
19 };
20}