aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/webapps/yourls/plugins/ldap/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/webapps/yourls/plugins/ldap/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/webapps/yourls/plugins/ldap/default.nix')
-rw-r--r--flakes/mypackages/pkgs/webapps/yourls/plugins/ldap/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/webapps/yourls/plugins/ldap/default.nix b/flakes/mypackages/pkgs/webapps/yourls/plugins/ldap/default.nix
new file mode 100644
index 0000000..5870faa
--- /dev/null
+++ b/flakes/mypackages/pkgs/webapps/yourls/plugins/ldap/default.nix
@@ -0,0 +1,17 @@
1{ stdenv, fetchFromGitHub }:
2stdenv.mkDerivation (rec {
3 pname = "yourls-ldap-plugin";
4 version = "2a3cb03-master";
5 src = fetchFromGitHub {
6 owner = "k3a";
7 repo = "yourls-ldap-plugin";
8 rev = "2a3cb0334b8a6b81b284a7196e614bbd2b2b1615";
9 sha256 = "0cchbnli77d295lzf7kjmn4dcxj2bmdqa9qc3f8l8qgmp4n5n0gh";
10 fetchSubmodules = true;
11 };
12 installPhase = ''
13 mkdir -p $out
14 cp plugin.php $out
15 '';
16 passthru.pluginName = "ldap";
17})