aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/webapps/rompr/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/webapps/rompr/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/webapps/rompr/default.nix')
-rw-r--r--flakes/mypackages/pkgs/webapps/rompr/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/webapps/rompr/default.nix b/flakes/mypackages/pkgs/webapps/rompr/default.nix
new file mode 100644
index 0000000..5b3e7e0
--- /dev/null
+++ b/flakes/mypackages/pkgs/webapps/rompr/default.nix
@@ -0,0 +1,17 @@
1{ varDir ? "/var/lib/rompr", stdenv, fetchFromGitHub }:
2stdenv.mkDerivation ({
3 pname = "rompr";
4 version = "1.24";
5 src = fetchFromGitHub {
6 owner = "fatg3erman";
7 repo = "RompR";
8 rev = "0d8f597027ac71b320963fe3f33f461a136312ad";
9 sha256 = "13p3c4whhmvz1vvh9fva5gdx4xji288k108hjdi8b1yn506lzix2";
10 fetchSubmodules = true;
11 };
12 installPhase = ''
13 cp -a . $out
14 ln -sf ${varDir}/prefs $out/prefs
15 ln -sf ${varDir}/albumart $out/albumart
16 '';
17})