aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/webapps/nextcloud/apps/passman.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/webapps/nextcloud/apps/passman.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/webapps/nextcloud/apps/passman.nix')
-rw-r--r--flakes/mypackages/pkgs/webapps/nextcloud/apps/passman.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/webapps/nextcloud/apps/passman.nix b/flakes/mypackages/pkgs/webapps/nextcloud/apps/passman.nix
new file mode 100644
index 0000000..5559b22
--- /dev/null
+++ b/flakes/mypackages/pkgs/webapps/nextcloud/apps/passman.nix
@@ -0,0 +1,21 @@
1{ buildApp, nextcloudVersion }:
2let
3 passman_2_4_5 = buildApp rec {
4 appName = "passman";
5 version = "2.4.5";
6 url = "https://releases.passman.cc/${appName}_${version}.tar.gz";
7 sha256 = "sha256-wcRx1lUEHbJBJBBSKOScGljOgHM7Vpf69OymJoI8S2Y=";
8 };
9 passman_2_4_7 = buildApp rec {
10 appName = "passman";
11 version = "2.4.7";
12 url = "https://releases.passman.cc/${appName}_${version}.tar.gz";
13 sha256 = "sha256-CeNaN0cioVjcW6ILB//BIvmjQWcbvfK3m8jVQ8LGtyM=";
14 };
15 versions = {
16 "25" = passman_2_4_5;
17 "26" = passman_2_4_7;
18 "27" = passman_2_4_7;
19 };
20in
21 versions."${builtins.toString nextcloudVersion}" or (throw "Unsupported version for nextcloud app passman")