aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/webapps/nextcloud/apps/gpxpod.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/webapps/nextcloud/apps/gpxpod.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/webapps/nextcloud/apps/gpxpod.nix')
-rw-r--r--flakes/mypackages/pkgs/webapps/nextcloud/apps/gpxpod.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/webapps/nextcloud/apps/gpxpod.nix b/flakes/mypackages/pkgs/webapps/nextcloud/apps/gpxpod.nix
new file mode 100644
index 0000000..5a3b7e7
--- /dev/null
+++ b/flakes/mypackages/pkgs/webapps/nextcloud/apps/gpxpod.nix
@@ -0,0 +1,31 @@
1{ buildApp, nextcloudVersion }:
2let
3 otherConfig = {
4 mimetypealiases = {
5 "application/gpx+xml" = "gpx";
6 };
7 mimetypemapping = {
8 "gpx" = ["application/gpx+xml"];
9 };
10 };
11 gpxpod_5_0_10 = buildApp rec {
12 appName = "gpxpod";
13 version = "5.0.10";
14 url = "https://github.com/julien-nc/gpxpod/releases/download/v${version}/${appName}-${version}.tar.gz";
15 sha256 = "sha256-Ylhl9jdOxG+Qfk5zgNO8FwOtAzrjGHS66y59qmorXPU=";
16 inherit otherConfig;
17 };
18 gpxpod_5_0_12 = buildApp rec {
19 appName = "gpxpod";
20 version = "5.0.12";
21 url = "https://github.com/julien-nc/gpxpod/releases/download/v${version}/${appName}-${version}.tar.gz";
22 sha256 = "sha256-uhz6AC8opDQkFQDpG4u8H4vkFtzbFAZvb8r32QHj/8I=";
23 inherit otherConfig;
24 };
25 versions = {
26 "25" = gpxpod_5_0_10;
27 "26" = gpxpod_5_0_12;
28 "27" = gpxpod_5_0_12;
29 };
30in
31 versions."${builtins.toString nextcloudVersion}" or (throw "Unsupported version for nextcloud app gpxpod")