aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/webapps/nextcloud/apps/drawio.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/webapps/nextcloud/apps/drawio.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/webapps/nextcloud/apps/drawio.nix')
-rw-r--r--flakes/mypackages/pkgs/webapps/nextcloud/apps/drawio.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/webapps/nextcloud/apps/drawio.nix b/flakes/mypackages/pkgs/webapps/nextcloud/apps/drawio.nix
new file mode 100644
index 0000000..c03c479
--- /dev/null
+++ b/flakes/mypackages/pkgs/webapps/nextcloud/apps/drawio.nix
@@ -0,0 +1,24 @@
1{ buildApp, nextcloudVersion }:
2let
3 otherConfig = {
4 mimetypealiases = {
5 "application/x-drawio" = "drawio";
6 };
7 mimetypemapping = {
8 "drawio" = ["application/x-drawio"];
9 };
10 };
11 drawio_2_1_2 = buildApp rec {
12 appName = "drawio";
13 version = "2.1.2";
14 url = "https://github.com/jgraph/drawio-nextcloud/releases/download/v${version}/${appName}-v${version}.tar.gz";
15 sha256 = "sha256-5BrEnS2cMk/vwkAr1lXKtfocqReZAj1+pbDqmi/uG0A=";
16 inherit otherConfig;
17 };
18 versions = {
19 "25" = drawio_2_1_2;
20 "26" = drawio_2_1_2;
21 "27" = drawio_2_1_2;
22 };
23in
24 versions."${builtins.toString nextcloudVersion}" or (throw "Unsupported version for nextcloud app drawio")