aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/webapps/nextcloud/apps/deck.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/webapps/nextcloud/apps/deck.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/webapps/nextcloud/apps/deck.nix')
-rw-r--r--flakes/mypackages/pkgs/webapps/nextcloud/apps/deck.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/webapps/nextcloud/apps/deck.nix b/flakes/mypackages/pkgs/webapps/nextcloud/apps/deck.nix
new file mode 100644
index 0000000..c5dd2d3
--- /dev/null
+++ b/flakes/mypackages/pkgs/webapps/nextcloud/apps/deck.nix
@@ -0,0 +1,27 @@
1{ buildApp, nextcloudVersion }:
2let
3 deck_1_8_5 = buildApp rec {
4 appName = "deck";
5 version = "1.8.5";
6 url = "https://github.com/nextcloud-releases/${appName}/releases/download/v${version}/${appName}-v${version}.tar.gz";
7 sha256 = "sha256-KsSSl9orqMEKJlBftHwCi/dh+aMCxZqjS7kPT0uDZlE=";
8 };
9 deck_1_9_2 = buildApp rec {
10 appName = "deck";
11 version = "1.9.2";
12 url = "https://github.com/nextcloud-releases/${appName}/releases/download/v${version}/${appName}-v${version}.tar.gz";
13 sha256 = "sha256-h1fmT4CCEFDZPBwFDIBLmFGJmO1Wt3a5nVXX5xCk0o0=";
14 };
15 deck_1_10_0 = buildApp rec {
16 appName = "deck";
17 version = "1.10.0";
18 url = "https://github.com/nextcloud-releases/${appName}/releases/download/v${version}/${appName}-v${version}.tar.gz";
19 sha256 = "sha256-W0XVvhTQoCjoK7S2tEd7bvU0MTWtqYt7QiB9H1p1UP8=";
20 };
21 versions = {
22 "25" = deck_1_8_5;
23 "26" = deck_1_9_2;
24 "27" = deck_1_10_0;
25 };
26in
27 versions."${builtins.toString nextcloudVersion}" or (throw "Unsupported version for nextcloud app deck")