aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/webapps/infcloud/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/webapps/infcloud/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/webapps/infcloud/default.nix')
-rw-r--r--flakes/mypackages/pkgs/webapps/infcloud/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/webapps/infcloud/default.nix b/flakes/mypackages/pkgs/webapps/infcloud/default.nix
new file mode 100644
index 0000000..45354fa
--- /dev/null
+++ b/flakes/mypackages/pkgs/webapps/infcloud/default.nix
@@ -0,0 +1,19 @@
1{ infcloud_config ? ./infcloud_config.js, stdenv, fetchzip, ed }:
2stdenv.mkDerivation rec {
3 version = "0.13.2rc1";
4 name = "InfCloud-${version}";
5 src = fetchzip {
6 url = "https://www.inf-it.com/InfCloud_${version}.zip";
7 sha256 = "1qgw6l7ccfkyzcw9dxcjwhxw9q27c0x9w584amc579mmrn9ppz3n";
8 };
9 buildPhase = ''
10 patchShebangs .
11 ./cache_update.sh
12 rm config.js
13 '';
14 installPhase = ''
15 cp -a . $out
16 ln -s ${infcloud_config} $out/config.js
17 '';
18 buildInputs = [ ed ];
19}