aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/telethon_sync/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/telethon_sync/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/telethon_sync/default.nix')
-rw-r--r--flakes/mypackages/pkgs/telethon_sync/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/telethon_sync/default.nix b/flakes/mypackages/pkgs/telethon_sync/default.nix
new file mode 100644
index 0000000..a03e1c3
--- /dev/null
+++ b/flakes/mypackages/pkgs/telethon_sync/default.nix
@@ -0,0 +1,24 @@
1{ lib, python3Packages, fetchgit }:
2with python3Packages;
3buildPythonPackage rec {
4 pname = "Telethon-sync";
5 version = "1.1.1";
6
7 src = fetchgit {
8 url = "https://github.com/LonamiWebs/Telethon";
9 branchName = "sync-stale";
10 rev = "6a785a01aa56cfd21c8c5beb9d722c68d664ba5e";
11 sha256 = "0g7gnln5kbh1gy6sfb3jg6knmi33n6sgzy2rni2x6af84lza0lgc";
12 };
13
14 propagatedBuildInputs = [
15 rsa pyaes async_generator
16 ];
17 doCheck = false;
18
19 meta = with lib; {
20 homepage = https://github.com/LonamiWebs/Telethon;
21 description = "Full-featured Telegram client library for Python 3";
22 license = licenses.mit;
23 };
24}