aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/telegram-history-dump
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/telegram-history-dump
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/telegram-history-dump')
-rw-r--r--flakes/mypackages/pkgs/telegram-history-dump/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/telegram-history-dump/default.nix b/flakes/mypackages/pkgs/telegram-history-dump/default.nix
new file mode 100644
index 0000000..492e265
--- /dev/null
+++ b/flakes/mypackages/pkgs/telegram-history-dump/default.nix
@@ -0,0 +1,18 @@
1{ stdenv, ruby, fetchFromGitHub }:
2stdenv.mkDerivation ({
3 pname = "telegram-history-dump";
4 version = "468ea91-master";
5 src = fetchFromGitHub {
6 owner = "tvdstaaij";
7 repo = "telegram-history-dump";
8 rev = "468ea91e543529b54bc2c5ea28b1ea17f362fd3e";
9 sha256 = "1wmwiqacfa56bmwx50njnb15cg0fy6rbdrmrjd4xfbh8bs6yp0gh";
10 fetchSubmodules = true;
11 };
12 installPhase = ''
13 mkdir -p $out/lib $out/bin
14 cp -a $src $out/lib/telegram-history-dump
15 ln -s $out/lib/telegram-history-dump/telegram-history-dump.rb $out/bin/telegram-history-dump
16 '';
17 buildInputs = [ ruby ];
18})