aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/proftpd/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/proftpd/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/proftpd/default.nix')
-rw-r--r--flakes/mypackages/pkgs/proftpd/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/proftpd/default.nix b/flakes/mypackages/pkgs/proftpd/default.nix
new file mode 100644
index 0000000..8bdf531
--- /dev/null
+++ b/flakes/mypackages/pkgs/proftpd/default.nix
@@ -0,0 +1,22 @@
1{ stdenv, fetchurl, file, openssl, libsodium, ncurses, cyrus_sasl, openldap, pkg-config, libxcrypt }:
2
3stdenv.mkDerivation rec {
4 pname = "proftpd";
5 version = "1.3.8";
6 src = fetchurl {
7 url = "https://github.com/proftpd/proftpd/archive/refs/tags/v${version}.tar.gz";
8 sha256 = "sha256-9xOec3eiywWbi5sU12pt9fRA4xgcsVrokNQ7vK5XR0g=";
9 };
10 postPatch = ''
11 sed -i -e "s@/usr/bin/file@${file}/bin/file@" configure
12 '';
13 dontDisableStatic = 1;
14 configureFlags = [ "--enable-openssl" "--with-modules=mod_ldap:mod_sftp:mod_tls:mod_site_misc" "--with-includes=${libsodium.dev}/include" "--with-libraries=${libsodium}/lib" ];
15 preInstall = ''
16 installFlagsArray=(INSTALL_USER=$(id -u) INSTALL_GROUP=$(id -g))
17 '';
18 buildInputs = [ openssl libsodium ncurses cyrus_sasl openldap pkg-config libxcrypt ];
19 postInstall = ''
20 rmdir $out/var $out/libexec $out/lib/proftpd $out/share/locale
21 '';
22}